Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-1607

Code dependency on PHP V4 in questiontypes.class.php

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.6
    • Fix Version/s: 1.9.6
    • Component/s: Module: Questionnaire
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      In questiontypes.class.php, there is a code construct using a function and an object that is not valid in pre-V5 PHP. An example is:

      $content = choice_values($choice->content)->text;

      Since Moodle 1.9 should work in V4 versions of PHP, this should be fixed.

        Attachments

          Activity

            People

            Assignee:
            mchurch Mike Churchward
            Reporter:
            mchurch Mike Churchward
            Participants:
            Component watchers:
            Mike Churchward
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              21/Oct/09