Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-1639

questionnaire broken in 2.0 again

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.0
    • Component/s: Module: Questionnaire
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      using moodle 2.0 dev (Build: 20091117)
      Impossible to create a new questionnaire
      error message : Coding error detected, it must be fixed by a programmer: A link must have a descriptive text value! See $OUTPUT->link_to_popup() for usage.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              mchurch Mike Churchward added a comment -

              This is all part of the 2.0 refactoring...

              mchurch Mike Churchward added a comment - - edited

              Actually, the message posted is caused by an issue in the Moodle formslib (MDL-20920). The same issue exists with the forum module and the assignment module.
              There was another warning related to use of 'htmleditor' which is related to CONTRIB-1483.

              The fact that you cannot save a new questionnaire is a new error. The messages related to that are:

              Notice: Undefined property: stdClass::$introeditor in /var/www/moodle-head/course/modedit.php on line 432
               
              Warning: mysqli::real_escape_string() expects parameter 1 to be string, array given in /var/www/moodle-head/lib/dml/mysqli_native_moodle_database.php on line 542
               
              Notice: Undefined index: intro in /var/www/moodle-head/lib/dml/mysqli_native_moodle_database.php on line 907
               
              Error writing to database
               
              More information about this error
              Debug info: Unknown column 'intro' in 'field list'<br /><br />UPDATE mdl_questionnaire SET intro = NULL WHERE id = ?<br />[array ( 0 =&gt; 4, )]
              Stack trace:
               
                  * line 375 of /lib/dml/moodle_database.php: dml_write_exception thrown
                  * line 922 of /lib/dml/mysqli_native_moodle_database.php: call to moodle_database->query_end()
                  * line 1394 of /lib/dml/moodle_database.php: call to mysqli_native_moodle_database->set_field_select()
                  * line 462 of /course/modedit.php: call to moodle_database->set_field()

              This may be related to http://moodle.org/mod/forum/discuss.php?d=138410.

              mchurch Mike Churchward added a comment -

              Part of the problem...

              mchurch Mike Churchward added a comment - - edited

              This issue appears to be caused by this:
              http://moodle.org/mod/forum/discuss.php?d=138410

              mchurch Mike Churchward added a comment -

              Updated "summary" field to use "intro" instead. Added "introformat".

              rezeau Joseph Rézeau added a comment -

              Questionnaire broken again in 2.0
              When creating a new questionnaire, I get the following:

              Error writing to database

              Debug info: Field 'intro' doesn't have a default value<br /><br />INSERT INTO mdl_questionnaire (name,opendate,closedate,qtype,respondenttype,resp_view,resume,grade,course,sid,timemodified,navigate) VALUES(?,?,?,?,?,?,?,?,?,?,?,?)<br />[array ( 0 => 'rrrrrrrrrrrrrrr', 1 => 0, 2 => 0, 3 => '0', 4 => 'fullname', 5 => '0', 6 => 0, 7 => '0', 8 => '2', 9 => '8', 10 => 1264011598, 11 => 1, )]
              Stack trace:

              • line 375 of \lib\dml\moodle_database.php: dml_write_exception thrown
              • line 740 of \lib\dml\mysqli_native_moodle_database.php: call to moodle_database->query_end()
              • line 783 of \lib\dml\mysqli_native_moodle_database.php: call to mysqli_native_moodle_database->insert_record_raw()
              • line 136 of \mod\questionnaire\lib.php: call to mysqli_native_moodle_database->insert_record()
              • line 439 of \course\modedit.php: call to questionnaire_add_instance()

              Joseph

              rezeau Joseph Rézeau added a comment -

              fixed - may need refinement


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    24/Nov/10