Details

    • Type: Task Task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: Module: Dialogue
    • Labels:
      None
    • Rank:
      21334

      Description

      Upgrade Dialogue module code to 2.0

        Activity

        Hide
        Ashley Holman added a comment -

        Hi -

        Just wondering what is the status of this upgrade?

        I need to have this available soon hence will commit development resources to get this done. Has there been any work done to date that I could use as a starting point, or shall we start from scratch with the 1.9 code?

        Cheers

        Show
        Ashley Holman added a comment - Hi - Just wondering what is the status of this upgrade? I need to have this available soon hence will commit development resources to get this done. Has there been any work done to date that I could use as a starting point, or shall we start from scratch with the 1.9 code? Cheers
        Hide
        Troy Williams added a comment -

        Hi Ashley,

        Not in working order, I would say 10-15% due to other project commitments at end of last year. I am focusing on it now. After some experimentation over the last few days I have made some changes to what was the proposed db schema and will update spec doc. Also will try break up into development tasks, so that others can help out development if like. I will post up some more information later this week.

        Regards,

        Troy

        Show
        Troy Williams added a comment - Hi Ashley, Not in working order, I would say 10-15% due to other project commitments at end of last year. I am focusing on it now. After some experimentation over the last few days I have made some changes to what was the proposed db schema and will update spec doc. Also will try break up into development tasks, so that others can help out development if like. I will post up some more information later this week. Regards, Troy
        Hide
        Sergey Vidusov added a comment -

        I attached the file containing the version which works for Moodle 2.0, including backup/restore.

        Show
        Sergey Vidusov added a comment - I attached the file containing the version which works for Moodle 2.0, including backup/restore.
        Hide
        Ashley Holman added a comment -

        Sergey's code is now on github as a fork:

        https://github.com/netspotau/moodle-mod_dialogue

        Show
        Ashley Holman added a comment - Sergey's code is now on github as a fork: https://github.com/netspotau/moodle-mod_dialogue
        Hide
        Troy Williams added a comment -

        Great! Many thanks Sergey and Ashley for the Moodle 2 conversion
        I have a half finished conversion. Does this conversion allow from upgrades from 1.9.x to 2.x?

        Show
        Troy Williams added a comment - Great! Many thanks Sergey and Ashley for the Moodle 2 conversion I have a half finished conversion. Does this conversion allow from upgrades from 1.9.x to 2.x?
        Hide
        Troy Williams added a comment -

        Hi,

        Conversion available at: https://github.com/troywilliams/moodle-mod_dialogue/tree/MOODLE_20_STABLE

        Handles upgrading from 1.9x to 2.0x

        Regards,

        Troy

        Show
        Troy Williams added a comment - Hi, Conversion available at: https://github.com/troywilliams/moodle-mod_dialogue/tree/MOODLE_20_STABLE Handles upgrading from 1.9x to 2.0x Regards, Troy
        Hide
        Felicia Berryman added a comment -

        By the comment above, is this module available as stable and ready for Moodle 2.x? From what I see at http://docs.moodle.org/20/en/Dialogue_module and http://docs.moodle.org/en/Development:Dialogue_2.0_specification I'd say no, but the above comment makes me think that there is a possibility that it is ready. Thanks!

        Show
        Felicia Berryman added a comment - By the comment above, is this module available as stable and ready for Moodle 2.x? From what I see at http://docs.moodle.org/20/en/Dialogue_module and http://docs.moodle.org/en/Development:Dialogue_2.0_specification I'd say no, but the above comment makes me think that there is a possibility that it is ready. Thanks!
        Hide
        Teresa Gibbison added a comment -

        Hi Felicia
        We have upgraded the Dialogue module for 2.0x - see the entry in the new Plugins database (URL: http://moodle.org/plugins/view.php?plugin=mod_dialogue). Work will continue on the http://docs.moodle.org/dev/Dialogue_2.0_specification improvements next year. Thanks for the reminder to update the docs page
        Cheers
        Teresa

        Show
        Teresa Gibbison added a comment - Hi Felicia We have upgraded the Dialogue module for 2.0x - see the entry in the new Plugins database (URL: http://moodle.org/plugins/view.php?plugin=mod_dialogue ). Work will continue on the http://docs.moodle.org/dev/Dialogue_2.0_specification improvements next year. Thanks for the reminder to update the docs page Cheers Teresa
        Hide
        Felicia Berryman added a comment -

        Happy to help! Also, I was thinking of Dialogue as a messaging tool, so I didn't even look under Activities at http://moodle.org/plugins/. Yes, I know, I should have searched too. I will be testing this plugin out soon. I'll keep watching this in case I have anything else to contribute. Thanks for the info.

        Show
        Felicia Berryman added a comment - Happy to help! Also, I was thinking of Dialogue as a messaging tool, so I didn't even look under Activities at http://moodle.org/plugins/ . Yes, I know, I should have searched too. I will be testing this plugin out soon. I'll keep watching this in case I have anything else to contribute. Thanks for the info.
        Hide
        Craig Drayton added a comment -

        Hi Troy and Teresa,

        Will the new version at http://moodle.org/plugins/view.php?plugin=mod_dialogue work for Moodle 2.1.X, or 2.0.X only?

        If the latter, any idea when there will be a 2.1.X version available?

        Thanks,
        Craig

        Show
        Craig Drayton added a comment - Hi Troy and Teresa, Will the new version at http://moodle.org/plugins/view.php?plugin=mod_dialogue work for Moodle 2.1.X, or 2.0.X only? If the latter, any idea when there will be a 2.1.X version available? Thanks, Craig
        Hide
        Troy Williams added a comment -

        Hi Craig,

        I have done quick test under 2.2 and seems fine. I haven't created a 2.1 branch, but there should be no reason why 2.0 code doesn't work under 2.1. I will setup branch and test, may be a few days. However latest code is located at:

        https://github.com/troywilliams/moodle-mod_dialogue

        Regards,

        Troy

        Show
        Troy Williams added a comment - Hi Craig, I have done quick test under 2.2 and seems fine. I haven't created a 2.1 branch, but there should be no reason why 2.0 code doesn't work under 2.1. I will setup branch and test, may be a few days. However latest code is located at: https://github.com/troywilliams/moodle-mod_dialogue Regards, Troy
        Hide
        Craig Drayton added a comment -

        Hi Troy,

        I've just done a quick test in 2.1 and we're now installing on production.

        Thanks for the good work and quick response

        Cheers,
        Craig

        Show
        Craig Drayton added a comment - Hi Troy, I've just done a quick test in 2.1 and we're now installing on production. Thanks for the good work and quick response Cheers, Craig
        Hide
        Troy Williams added a comment -

        Closing off old task that should of been closed years back.

        Show
        Troy Williams added a comment - Closing off old task that should of been closed years back.

          People

          • Votes:
            7 Vote for this issue
            Watchers:
            11 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development