Add-ons
  1. Add-ons
  2. CONTRIB-2135

Restoring course with a link to a public questionnaire creates a duplicate questionnaire

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Not a bug
    • Affects Version/s: 1.9.8
    • Fix Version/s: None
    • Component/s: Module: Questionnaire
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      22712

      Description

      Doing a backup and restore of a course with a link to a Public Questionnaire doesn't behave as expected.

      Create a public questionnaire in one course. In a second course, add a questionnaire activity that points to the original questionnaire with the "Use Public" option. Backup the second course and restore to a new course. A new copy of the original public questionnaire is created in the restored course, resulting in a duplicate public questionnaire. (The advanced settings tab, ability to view responses and change questions are available in the restored course for this new questionnaire. The course restored from did not have these options, since the questionnaire lived elsewhere.)

      What I would expect would be that the restored course should link back to the original pubic questionnaire like it's source course did, rather than creating a second copy of the questionnaire.

        Activity

        Joseph Rézeau added a comment -

        As far as I can remember, this is a known bug of the Questionnaire module. And it will very likely not be fixed. Sorry.

        Mike Churchward added a comment -

        Unfortunately, there is no way to do that. If you restore a course with a questionnaire that is "using" a public questionnaire, there is no way to verify that the questionnaire is is "using" is the same one as it was when it was backed up. Therefore, no connection can be restored. Instead, it creates a new questionnaire in the course.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development