Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-2577

ForumNG - 'view posts by user' fails for clone forums (Bug 10979)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.10
    • Fix Version/s: 1.9.10
    • Component/s: None
    • Labels:
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      The original Forum called 'Shared_ForumNG' is on B201-10B and I have shared
      this forum with DSE232-10I and K101-10J.
      The view posts by user is now working for the original forum and the shared
      forum on K101-10J. But it is still not working for the DSE232-10I course. Still
      gives a no permissions error message.

      I see why this is happening. Unfortunately I think the only way we can properly
      fix it is to disable the 'view posts by user' feature for shared forums, which
      kind of sucks seeing we nearly made it work but I think we can't get past
      nearly...

      Ray, please could you:

      1) Change the code for showing the button, so that it does not show the button
      for shared forums.

      2) For consistency/security, change the list.php and user.php scripts so that
      they fail (just throw an exception I guess, no need for a detailed error
      message) if the forum is shared.

        Attachments

          Activity

            People

            • Assignee:
              guoruicn Ray Guo
              Reporter:
              guoruicn Ray Guo
              Participants:
              Component watchers:
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                25/Oct/10