Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-2716

Deprecation warning when installing

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 2.1
    • Component/s: Module: Questionnaire
    • Labels:
      None
    • Affected Branches:
      MOODLE_20_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE

      Description

      When I first installed mod_questionnaire in Moodle 2.0.1, the install/upgrade script spit out this warning

      componentname_capabilities array is deprecated, please use capabilities array only in access.php files
          line 3301 of /lib/accesslib.php: call to debugging()
          line 3398 of /lib/accesslib.php: call to load_capability_def()
          line 502 of /lib/upgradelib.php: call to update_capabilities()
          line 265 of /lib/upgradelib.php: call to upgrade_plugins_modules()
          line 1352 of /lib/upgradelib.php: call to upgrade_plugins()
          line 290 of /admin/index.php: call to upgrade_noncore()

      Other than that, the install went fine.

        Attachments

          Activity

            People

            Assignee:
            mchurch Mike Churchward
            Reporter:
            jk3us Jay Knight
            Participants:
            Component watchers:
            Mike Churchward
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              1/Jul/11