Add-ons
  1. Add-ons
  2. CONTRIB-2758

errors in view.php, chapterlib.php, mod_form.php,

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9.10
    • Fix Version/s: 1.9.11
    • Component/s: Module: Presenter
    • Labels:
      None
    • Environment:
      Win XP Pro sp3, Mozilla Firefox browser, PHP version 5.1.6
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      23456

      Description

      The presenter Module displays the picture and plays the mp3 file. The page is not laid out according to the template. I get errors with view.php and chapterlib.php files:
      Notice: Undefined variable: presentationWidth in /srv/moodle/web/mod/presenter/view.php on line 120

      Notice: Undefined variable: ch in /srv/moodle/web/mod/presenter/chapterlib.php on line 81

      Notice: Trying to get property of non-object in /srv/moodle/web/mod/presenter/chapterlib.php on line 81

      Notice: Undefined variable: ch in /srv/moodle/web/mod/presenter/chapterlib.php on line 82

      Notice: Trying to get property of non-object in /srv/moodle/web/mod/presenter/chapterlib.php on line 82

      Notice: Undefined variable: slideHeightDiv in /srv/moodle/web/mod/presenter/view.php on line 534

      Notice: Undefined variable: pageWidth in /srv/moodle/web/mod/presenter/view.php on line 658

      When I edit the presenter, I get an error in the mod_form.php file:
      Notice: Undefined property: stdClass::$completion_factor in /srv/moodle/web/mod/presenter/mod_form.php on line 348

      I attached a screenshot of the output when the presenter plays which displays the errors

      1. First_Try_20110212_3.zip
        627 kB
        Daniel Fenske
      1. Capture.PNG
        421 kB

        Activity

        Hide
        Alex Contis added a comment -

        Some changes were done to:

        Modified:
        Presenter Module v2/presenter/chapterlib.php
        Presenter Module v2/presenter/mod_form.php
        Presenter Module v2/presenter/version.php
        Presenter Module v2/presenter/view.php

        I attached the latest version to PresenterModuleV2.zip

        Uninstall the previous version of Presenter, and delete the files from the server before you install the new version. Please test it and check if it solves your issues. Remember to clear the cache for your web browser.

        Show
        Alex Contis added a comment - Some changes were done to: Modified: Presenter Module v2/presenter/chapterlib.php Presenter Module v2/presenter/mod_form.php Presenter Module v2/presenter/version.php Presenter Module v2/presenter/view.php I attached the latest version to PresenterModuleV2.zip Uninstall the previous version of Presenter, and delete the files from the server before you install the new version. Please test it and check if it solves your issues. Remember to clear the cache for your web browser.
        Hide
        Daniel Fenske added a comment -

        The new install solved everything. Presenter works as documented. Thanks very much. We are pretty excited about using this module at our school!

        Show
        Daniel Fenske added a comment - The new install solved everything. Presenter works as documented. Thanks very much. We are pretty excited about using this module at our school!
        Hide
        Alemat Gebru added a comment -

        Hello Alix,
        how's going?
        hope and wish you great!
        I really thank you for contributing this Wonderful plugin.

        please help me fix the below problem!

        After creating presentation using the presenter module, i'm getting the below error on the FlowPlayer it self

        " 200, Stream not found, NetStream.Play.StreamNotFound, clip: '[Clip] 'http://172.30.70.229/moodle/mod/presenter/flowplayer_streamer.php/DrFords.flv''

        i have big project right now and i'm using the module to display multimedia objects.

        but its not working.

        i'm using moodle 2.01
        in windows server 2008

        please email me : alematgebru@gmail.com

        I'm thanking you for your kind attention and hope to hear from you soon.

        Show
        Alemat Gebru added a comment - Hello Alix, how's going? hope and wish you great! I really thank you for contributing this Wonderful plugin. please help me fix the below problem! After creating presentation using the presenter module, i'm getting the below error on the FlowPlayer it self " 200, Stream not found, NetStream.Play.StreamNotFound, clip: ' [Clip] 'http://172.30.70.229/moodle/mod/presenter/flowplayer_streamer.php/DrFords.flv'' i have big project right now and i'm using the module to display multimedia objects. but its not working. i'm using moodle 2.01 in windows server 2008 please email me : alematgebru@gmail.com I'm thanking you for your kind attention and hope to hear from you soon.
        Hide
        Lynn Harvey added a comment -

        " 200, Stream not found, NetStream.Play.StreamNotFound, clip: '[Clip] 'http://.........../moodle/mod/presenter/flowplayer_streamer.php/whatever.flv''

        not all flv's have the same codec
        discovered files converted using zamzar gave us the above error
        but those converted on keepvid worked fine

        Show
        Lynn Harvey added a comment - " 200, Stream not found, NetStream.Play.StreamNotFound, clip: ' [Clip] 'http://.........../moodle/mod/presenter/flowplayer_streamer.php/whatever.flv'' not all flv's have the same codec discovered files converted using zamzar gave us the above error but those converted on keepvid worked fine

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development