Details

    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      23082

      Description

      Drag and drop does not work in IE9.

        Activity

        Jeff Therrien created issue -
        Adriane Boyd added a comment -

        It's probably a YUI2 compatibility issue, or at least that's what I'd suspect first. The YUI developers intend to support it (http://developer.yahoo.com/yui/articles/gbs/ ), but they probably haven't time yet to address any issues with the final release.

        Unfortunately I have no way to try anything out with IE9, so I have no way to figure out what's going on. If you could describe exactly what's going wrong and/or describe any specific error messages, I might be able to help you, but it's not all that likely. (Debugging these questions types in IE6 in 2007 made me want to hunt down and fire all IE developers.)

        Jeff Therrien added a comment -

        I think you're right about it being a YUI issue: http://yuilibrary.com/projects/yui2/ticket/2529263

        I couldn't find any error messages in the console. Basically, once you click on the item to drag it, nothing happens. The "clone" item isn't made or anything.

        Adriane Boyd added a comment -

        See also: http://yuilibrary.com/projects/yui2/ticket/2529136

        It looks like this will be fixed in YUI 2.9.0, which hasn't been released yet. If you are willing to do some cross-browser testing, you could download the current development version here: https://github.com/yui/yui2/tree/master/build/ and replace your moodle/lib/yui directory with this version (just the code from the build directory) until 2.9.0 is out. I don't have a good feel for how unstable the development version is, but you could certainly give it a shot.

        Andy Braden added a comment -

        As a workaround the user should be able to use the compatibility mode toggle in IE9 to get it to work. I have tested this successfully for the Drag and Drop question type.

        Adriane Boyd added a comment -

        Thanks for the tip!

        Adam Meeker added a comment - - edited

        Got this to work in IE9 by installing YUI 2.9.0. Seems to work fine with or without Compatibility Mode enabled. Here's how I installed YUI 2.9.0:

        1) Download yui_2.9.0.zip from http://yuilibrary.com/downloads/, extract, and copy the build folder into a new folder: [moodleroot]/lib/yui/2.9.0

        2) Download config_2.9.0.php from https://github.com/yui/phploader/blob/master/lib/meta/config_2.9.0.php and copy it to [moodleroot]/lib/yui/phploader/lib/meta/

        3) Download json_2.9.0.txt from https://github.com/yui/phploader/blob/master/lib/meta/json_2.9.0.txt and copy it to [moodleroot]/lib/yui/phploader/lib/meta/

        4) Edit [moodleroot]/lib/setup.php around line 202. Change

        $CFG->yui2version = '2.8.2';

        to

        $CFG->yui2version = '2.9.0';

        5) Not sure if necessary, but I purged all caches.

        Drag-and-Drop ordering questions now work in IE9. Hopefully upgrading yui to 2.9.0 didn't break anything. We've got Moodle 2.0.3 on Windows Server 2008 R2 (IIS7 and MS-SQL 2008 R2).

        John Cashman added a comment -

        The Drag the target onto the image functionality stopped working in IE9. For Moodle 1.9.9 I completed only step 1 as per Adam's instructions above with the exception that I replaced [moodleroot]/lib/yui with the build folder. (Moved the origial [moodleroot]/lib/yui directory to [moodleroot]/lib/yui-orig and renamed the 2.9.0 build directory to[moodleroot]/lib/yui). The drag target functionality is now working. Thanks to all and Adam S for instructions which helped resolve my issue.

        Murad Jamal added a comment -

        I have added an issue for this here: http://tracker.moodle.org/browse/MDL-28454
        please let somebody to commit the changes to head.
        thanks.

        Adriane Boyd added a comment -

        Thanks, Itamar, for maintaining these question types further!

        Adriane Boyd made changes -
        Field Original Value New Value
        Assignee Adriane Boyd [ adrianeboyd ] Itamar Tzadok [ itamart ]
        Jean-Michel Vedrine added a comment -

        I tested the latest version available in the Moodle plugin directory https://moodle.org/plugins/view.php?plugin=qtype_ddmatch with the latest version of IE10 (this is the only version I have access to) and all seems to be working as expected.
        So as this issue has not seen any action for some time, I will close it as "can't reproduce", please open a new tracker issue if you have any problem with a specific browser.

        Jean-Michel Vedrine made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Assignee Itamar Tzadok [ itamart ] Jean-Michel Vedrine [ jmvedrine ]
        Resolution Cannot Reproduce [ 5 ]
        Jean-Michel Vedrine made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Votes:
            4 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development