Add-ons
  1. Add-ons
  2. CONTRIB-2864

ForumNG: clicking on Reply link when not logged in gives error

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.11
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      23105

      Description

      Moodle 1.9.11+ (Build: 20110316)
      ForumNG version: Stable R2.34

      1) Messages with attachments are not sent by email
      2) When not logged in to the platform, clicking on Reply to a message in a mailer leads to an error message (see attachment)

      Error messages in attachment - though I'm no longer getting the first two.

        Activity

        Sam Marshall added a comment -

        Hi,

        As you reported two bugs using a single issue, I have taken the liberty to define this bug as referring to your second issue, since I can reproduce it. The one about clicking a 'Reply' link when not logged in causing an error. I can reproduce this one and will fix it shortly.

        Regarding the attachment bug, I just tested as follows:
        1) create new forum, default settings
        2) subscribe to it
        3) add discussion, type some junk, select 'mail now', add an attachment (.csv file), post it
        4) add a reply, type junk, 'mail now', attachment (same .csv file), post it
        5) visit admin/cron.php to trigger email sending
        note - my settings on this server are set to default html email

        I received 2 emails, one corresponding to each post. Both emails contained correct links to the attachment. On clicking the link I was prompted to log in and then download the csv.

        If you can still reproduce the attachment bug and it is different to the one covered here (i.e. doesn't have that error message as shown in your word document) then please file as a new issue, along with detailed steps to reproduce. Also could you please look in your cron log (the thing that you see directly if you run admin/cron.php on a test server) and see if there are any error messages regarding the emails that weren't sent out because they had attachments - if so, please include these in the bug.

        Sam Marshall added a comment -

        OU bug 11615.

        Fixed in stable R3.5.

        Glenys Hanson added a comment -

        I confirm the Reply problem is solved. Thanks Sam.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development