Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: 1.9.12, 2.3
    • Fix Version/s: None
    • Component/s: Enrol: Banner/LMB
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE, MOODLE_23_STABLE
    • Rank:
      23335

      Description

      We've got a faculty member who keeps getting added to another faculty member's course as a teacher. We've manually removed him and he is automatically added back in. When I look a the XML, I see only the correct faculty member (Wendy) listed as a member of the course. There are several students listed too. The other faculty member (Jim) is listed in several of his own courses. The only oddity we can find is that Jim has a value in one of his userid fields that matches the sourced/id that Weber has. We're thinking perhaps the script is incorrectly matching to this field instead of the correct field.

      I've sent XML file snippets directly to Eric. We're using LMB 0.8.5.

        Activity

        Hide
        Adam Nave added a comment -

        I found another user this issue was occurring with, who also had the same type of unrelated userid matching another person's ID. I experimented with removing the particular userid field manually from the XML and I seem to have a workaround.

        Previous behavior:
        1. User erroneously appears in course after LMB import.
        2. Manually remove user from course.
        3. Run LMB import. User appears in course again.

        Workaround:
        1. Manually remove user from course.
        2. Manually edit XML file(s) to remove offending userid tag.
        3. Run LMB import on manually edited file. User does NOT reappear in course.
        4. Run LMB import on ORIGINAL (unedited) file. User does NOT reappear in course.

        So it seems like the issue may be intermittent or occur only under a specific set of conditions. If you have a version of the LMB plugin that can generate debug info I would be willing to try it.

        Thanks,
        --Adam

        Show
        Adam Nave added a comment - I found another user this issue was occurring with, who also had the same type of unrelated userid matching another person's ID. I experimented with removing the particular userid field manually from the XML and I seem to have a workaround. Previous behavior: 1. User erroneously appears in course after LMB import. 2. Manually remove user from course. 3. Run LMB import. User appears in course again. Workaround: 1. Manually remove user from course. 2. Manually edit XML file(s) to remove offending userid tag. 3. Run LMB import on manually edited file. User does NOT reappear in course. 4. Run LMB import on ORIGINAL (unedited) file. User does NOT reappear in course. So it seems like the issue may be intermittent or occur only under a specific set of conditions. If you have a version of the LMB plugin that can generate debug info I would be willing to try it. Thanks, --Adam
        Hide
        Adam Nave added a comment - - edited

        I'm not sure what was different about today's import, but one of the users is back in the wrong classes. The other is not.

        Show
        Adam Nave added a comment - - edited I'm not sure what was different about today's import, but one of the users is back in the wrong classes. The other is not.
        Hide
        Adam Nave added a comment -

        The second pair of users started having the crossover problem again. I'm trying the workaround.

        If there's any additional data I can get you or something I can run to get debug or extra logging info, please let me know.

        Show
        Adam Nave added a comment - The second pair of users started having the crossover problem again. I'm trying the workaround. If there's any additional data I can get you or something I can run to get debug or extra logging info, please let me know.
        Hide
        Eric Merrill added a comment -

        I'm sorry I didn't get back to you sooner :/

        Could you send me a pdf or screen shots of the lmb config page?

        Thanks
        -eric

        Show
        Eric Merrill added a comment - I'm sorry I didn't get back to you sooner :/ Could you send me a pdf or screen shots of the lmb config page? Thanks -eric
        Hide
        Adam Nave added a comment -

        I don't see a way to attach files so I sent it directly to you. Thanks.

        Show
        Adam Nave added a comment - I don't see a way to attach files so I sent it directly to you. Thanks.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:

              Development