Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-3220

error in the gradebook when I try to view the scales

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: Module: Adobeconnect
    • Labels:
      None
    • Affected Branches:
      MOODLE_21_STABLE

      Description

      Hi all,

      I get an error in the gradebook when I try to view the scales section either for a course or in site admin but while I post it here I don't know if its actually related to the Connect module. The error states Field "grade" does not exist in table "adobeconnect" but I haven't finished configuring the adobeconnect module

      If I disable the connect module the error goes away and I can access the scales settings

      I'm using Moodle 2.1+ (Build: 20110713) and the help documentation directs me to this http://docs.moodle.org/20/en/error/moodle/ddlfieldnotexist but that appears to be about the glossary

      Any suggestions as I hope to use the connect module when I upgrade my Connect 8 server to SP2

        Gliffy Diagrams

          Issue Links

            Activity

            murphy.wong Murphy Wong added a comment -

            I've the same problem on my Moodle 2.1.1. After upgrading to the latest Moodle 2.1.2, the problem persists. Finally, I try adding a field "grade" in the "adobeconnect" table and the scales is resume to normal. I know this is not a good solution but it stops the pain at the moment. I will drop the field before the next upgrade available from the Connect module. Useful SQL below:

            alter table mdl_adobeconnect add grade decimal(10,5) unsigned;

            alter table mdl_adobeconnect drop grade;

            Hope this help...

            murphy.wong Murphy Wong added a comment -

            A better solution is to update file ~moodle/mod/adobeconnect/lib.php function to stop the scale checking in Moodle 1.9 as below

            function adobeconnect_scale_used_anywhere($scaleid) {
            global $DB;

            // for debugging on 24 November 2011
            return false;

            $param = array('grade' => $scaleid);
            if ($scaleid and $DB->record_exists('adobeconnect', $param))

            { return true; }

            else

            { return false; }

            }

            diff lib.php.ori lib.php
            546a547,549
            > // for debugging on 24 November 2011
            > return false;
            >

            adelamarre Akin Delamarre added a comment -

            Thanks Murphy I will take a look at it. I've been quite busy but I do intend on making some updates to the code.

            mobcdi Michael OBrien added a comment -

            Out of interest, which option would you suggest would be the best (most suitable to resolve the problem & less likely to cause upgrade problems for the module later) if I needed to use the module as it stands

            adelamarre Akin Delamarre added a comment -

            Hello Michael,

            The solution you posted would be the best in my opinion. That linke of code in ..._scale_used_anywhere should simply return false, but it was left in my accident.

            Adobe's intention for this module was never to have it as a graded module.

            I haven't yet updated the code as I'm quite busy with another project. However, I do plan to release an update of the code.

            mocsap Pawel Kubzdyl added a comment -

            Hello,

            I have an identical problem. The problem is exactly the same as described for Moodle 2.1. Hovewer I'm using currently the Moodle version 2.6.2, so it should be fixed already. At the time when I'm trying to open the grading scale the following error appears:

            Field "grade" does not exist in table "adobeconnect

            This is the function from the file mod/adobeconnect/lib.php:

            /**

            • Checks if scale is being used by any instance of adobeconnect.
            • This function was added in 1.9
              *
            • This is used to find out if scale used anywhere
            • @param $scaleid int
            • @return boolean True if the scale is used by any adobeconnect
              */
              function adobeconnect_scale_used_anywhere($scaleid) {
              global $DB;

            $param = array('grade' => $scaleid);
            if ($scaleid and $DB->record_exists('adobeconnect', $param))

            { return true; }

            else

            { return false; }

            }

            My Moodle version 2.6.2, PHP 5.5.8

            Any hints why it happens once again?

            adelamarre Akin Delamarre added a comment -

            Hello Pawel, can you verify whether you have an updated stable copy of the code?

            Here is a link from our github account, the code you highlighted doesn't exist the MOODLE_26_STABLE version of the code.
            https://github.com/remotelearner/moodle-mod_adobeconnect/blob/MOODLE_26_STABLE/lib.php

            mocsap Pawel Kubzdyl added a comment -

            Dear Akin,

            indeed...my mistake. I need to make an update to the latest stable version of the Moodle 2.6.x

            After changing the library everything works as expected. Thank you.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Development