Plugins
  1. Plugins
  2. CONTRIB-3244

OU wiki: Import and duplicate do not include user data

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:

      Description

      Hi,
      tried to import OU wiki from one course to another.

      Expected to import the OU wiki with the pages.
      Instead imported an empty OU wiki - without the pages.
      please fix.
      10x

        Gliffy Diagrams

          Activity

          Michael de Raadt added a comment -

          Thanks for your report.

          I've shifted this over to the OU Wiki component in CONTRIB.

          Over to you, Sam.

          Sam Marshall added a comment -

          Thanks for reporting.

          We need more information in order to investigate the process you used. Could you describe the exact steps you used - for example 1) go to wiki, 2) click on backup, 3) leave default settings and click next... etc?

          Also can you confirm which version of ouwiki you are using.

          thanks...

          Sophia N added a comment -

          Hi,
          My steps:
          1. Went to my course
          2. Click "Import" in the Settings block
          3. Went through the import stages:
          1. Course selection / ► 2. Initial settings / ► 3. Schema settings / ► 4. Confirmation and review / ► 5. Perform import / ► 6. Complete
          4. Completed the import process
          5. Go to OUWiki
          6. Had no imported pages of the OUWiki, the wiki was empty

          Thank you!
          Sophia

          Sam Marshall added a comment -

          Thanks - I can reproduce it with those instructions.

          Having done that I also checked and can reproduce using the 'Duplicate' button (again this duplicates the wiki but not the data in pages). So it sounds like backup/restore of wiki user data is not working.

          I filed this as bug #2491 in our local system too so that we don't lose it. It might take us a while to get around to fixing it though (probably January some time), sorry.

          Sophia N added a comment -

          thank you for your quick response!
          Sophia

          Nadav Kavalerchik added a comment -

          We are following your development on https://github.com/moodleou/moodle-mod_ouwiki with RSS
          so i guess i will be looking fwd for that too
          (I am Sophia N's sys admin)
          Thanks Sam

          Sam Marshall added a comment -

          Sorry, after investigating this we have discovered that it is not a bug.

          1) When you do backup and restore (including user data), wiki pages are correctly backed up. [There is currently a problem with annotations which we are looking into, but the page content works.]

          2) Both the duplicate feature (that I reported) and the import feature (that was in the original report) do a backup and restore WITHOUT user data. The wiki pages are content created by users - in other words, user data - so they are not included.

          I did not know this before (about duplicate and import). It seems odd, especially in the case of duplicate: if I duplicate a wiki or forum I'd kind of expect it to contain the same pages or messages as the one I started with, or at least to have an option. But that appears to be correct Moodle behaviour, so there is no problem with OU wiki here.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development