Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 2.2.1
    • Fix Version/s: 2.2.1
    • Component/s: Block: Mrbs
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Rank:
      37553

      Description

      I installed the Moodle block MRBS from https://github.com/davosmith/moodle-mrbs/zipball/MOODLE_20_STABLE

      First of all I got an fatal error
      Notice: Undefined variable: cookie_path_override in /Library/WebServer/Documents/moodle22/blocks/mrbs/web/config.inc.php on line 199 Fatal error: Cannot access empty property in /Library/WebServer/Documents/moodle22/blocks/mrbs/web/config.inc.php on line 199

      This error comes from my site cookie path ... I had to delete the cookie path ... not a great idea because my testserver hosts 7 Moodle versions.

      The activated block MRBS results the following debug messages:
      context_system::instance(): invalid $id parameter detected, should be 0

      line 5542 of /lib/accesslib.php: call to debugging()
      line 6813 of /lib/accesslib.php: call to context_system::instance()
      line 43 of /blocks/mrbs/block_mrbs.php: call to get_context_instance()
      line 280 of /blocks/moodleblock.class.php: call to block_mrbs->get_content()
      line 232 of /blocks/moodleblock.class.php: call to block_base->formatted_contents()
      line 926 of /lib/blocklib.php: call to block_base->get_content_for_output()
      line 978 of /lib/blocklib.php: call to block_manager->create_block_contents()
      line 349 of /lib/blocklib.php: call to block_manager->ensure_content_created()
      line 8 of /theme/leatherbound/layout/frontpage.php: call to block_manager->region_has_content()
      line 685 of /lib/outputrenderers.php: call to include()
      line 637 of /lib/outputrenderers.php: call to core_renderer->render_page_layout()
      line ? of unknownfile: call to core_renderer->header()
      line 1363 of /lib/setuplib.php: call to call_user_func_array()
      line 91 of /index.php: call to bootstrap_renderer->__call()
      line 91 of /index.php: call to bootstrap_renderer->header()

      1. mrbs1.png
        229 kB
      2. mrbs2.png
        222 kB
      3. mrbs3.png
        120 kB

        Activity

        Davo Smith added a comment -

        I can see the first problem - clearly no one with custom cookie paths has ever used MRBS before, as there is a glaring typo on the line. I will fix as soon as I can.

        The second problem is a duplicate of CONTRIB-3321 and is in the process of being fixed.

        Davo Smith added a comment -

        I've fixed the cookie config issue, but marked it as a duplicate in terms of the warning messages about get_config_instance (those are being worked on and will be fixed shortly).


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development