Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-3385

Update from 1.8.7+(20081115) to 1.8.8+ (20090416) breaks media player in hot potato quiz window

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.11
    • Fix Version/s: None
    • Component/s: Module: HotPot
    • Labels:
      None
    • Environment:
      CentOS server, PHP 5.2.6, Apache 2.0.52
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      Site is using a large number or embeded audio clips for quizzes. Prior to the update to 1.8.8+ the quiz would show an audio player which students could listed to before attempting the quiz answers. After the update, the media player disappeared. On swapping out the new lib.php (1.66.2.23) for the old one (1.66.2.20) the player re-appeared and worked again. No error messages in the server logs or in debug that I could see. Couldn't test extensively as it is a client site.

        Attachments

        1. errors-1.fixed.htm
          56 kB
          Gordon Bateson
        2. errors-1.htm
          56 kB
          Paul Taylor
        3. listening-17-new.htm
          48 kB
          Paul Taylor

          Activity

            People

            Assignee:
            xxxxxxx Gordon Bateson
            Reporter:
            negations Paul Taylor
            Participants:
            Component watchers:
            Gordon Bateson
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: