Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-3431

When importing HotPotatoes quizzes, problem with non-ascii characters in response.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9.11
    • Fix Version/s: None
    • Component/s: Module: HotPot
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      When importing a question in the HotPotatoes format, non-ascii characters in the response part will not get converted, but passed on as html entities. Correct answer "prøve" will be "prøve" in the resulting quiz question.

      This only applies to import of questionsto the question bank in the HotPotatoes format (.xml), and not to HotPotatoes exercises added as .htm files.

        Attachments

        1. unicode.jcl.jpg
          unicode.jcl.jpg
          40 kB
        2. test_unicode.jcl
          3 kB
        3. test_unicode_ screen.png
          test_unicode_ screen.png
          6 kB
        4. test_unicode_ correct.png
          test_unicode_ correct.png
          18 kB
        5. editquestion_unicode.png
          editquestion_unicode.png
          1.17 MB

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: