Add-ons
  1. Add-ons
  2. CONTRIB-3514

Collapsed topic format resources not showing

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.1.2
    • Fix Version/s: None
    • Component/s: Course format: Topcoll
    • Labels:
      None
    • Database:
      MySQL
    • Workaround:

      create a course with a standard topic format, add resources and then change the format to collapsed topic

      Show
      create a course with a standard topic format, add resources and then change the format to collapsed topic
    • Affected Branches:
      MOODLE_21_STABLE
    • Rank:
      38585

      Description

      Created a new course with collapsed topic format and when resources are added, they do not appear. If you create a course with a standard topic format, add resources and then change the format to collapsed topic, the resources still show ok.
      Debugging developer level has produced an error when opening an affected course.

        Activity

        Gareth J Barnard added a comment -

        Dear Beverly,

        I'm using version 2.1.4+ (Build: 20120301) of Moodle and could not reproduce what you have described with the latest version 'Version 2.1.5.1' of Collapsed Topics as that could have altered the 'course_sections' table given the call stack you show i.e. 'line 1262 of /course/lib.php: call to moodle_database->get_records()' - I used a course creating teacher with the standard white theme and could add Label's etc. And did not get the debug issue with debugging on.

        I then examined your Collapsed Topic's Readme.txt 'http://onlinelearning.amttraining.com/course/format/topcoll/Readme.txt' to reveal that you are using 'Version 2.1.3.3' - so I reverted back to that version and repeated the steps above and could not reproduce the issue. Given that you have the file 'http://onlinelearning.amttraining.com/course/format/topcoll/arrow_down.png' in your version I assume that this is the correct one and you have not just performed an upgrade as in the latest version this file has moved.

        As this version is a two versions old can I ask if you have done anything recently? When did you install this version? What source was it from please - Moodle.org plugin's DB or GitHub? If possible, please zip up your version and attach it to this issue so I can check for alterations / incorrect file copies etc.

        Thanks,

        Gareth

        Gareth J Barnard added a comment -

        Dear Beverley,

        Please could you kindly provide the information requested so that I can solve this issue. Otherwise I will be forced to close it as 'Not a bug'.

        Regards,

        Gareth

        Beverley Booker added a comment -

        Gareth,

        Sorry about the delay in this. It is a client that I provide Moodle support to that has the issue and they have not yet got back to me. I have chased them, but obviously if they do not respond within the next few days, then I understand that the issue will be closed.

        Regards, Bev.

        Gareth J Barnard added a comment -

        Dear Bev,

        No problem, I totally understand. I will therefore keep this open for longer.

        I take great professional pride in my work on the format and wish to identify and fix any issues that arise as fast as possible for the benefit of those who use it. To be honest 19 times out of 20 the issue is related to something else that has been done incorrectly by the user and broken the format against the instructions in the Readme.txt file. However, every issue regardless can lead to new information, and sometimes if the issue is not a bug I still update the Readme.txt with information to help others not make the same mistake.

        My gut on this informs me that the browser is failing the page due to a coding fault that has been introduced somehow either though my code, an external change to my code or a theme conflict. Because it is failing, JavaScript no longer works and hence the addition of new resources which I believe needs JavaScript to operate therefore does not work.

        I maintain and develop the format for free in the hope that it is useful and to be honest gives me status as a credible employee with future employers.

        Regards,

        Gareth

        Beverley Booker added a comment -

        Gareth,

        Thank you for being so patient with this.
        My client is now going to upgrade Moodle, to see if that solves the issue, so Please go ahead and close this case.

        Regards, Bev.

        Gareth J Barnard added a comment -

        Dear Bev,

        No worries, please would you be so kind as to let me know of the upgrade solves their problem.

        Cheers,

        Gareth

        Gareth J Barnard added a comment -

        Unable to reproduce issue with supplied details.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development