Add-ons
  1. Add-ons
  2. CONTRIB-3532

When editing an appointment slot in the scheduler, all of the settings reset instead of retaining their original values

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1, 2.2
    • Fix Version/s: 2.2
    • Component/s: Module: Scheduler
    • Labels:
      None
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE
    • Rank:
      38803

      Description

      See discussion here: http://moodle.org/mod/forum/discuss.php?d=195093&parent=850046

      When editing an appointment slot, all of the slot's settings become reset instead of retaining their previous state.

      To test:

      1. Create a scheduler
      2. Create an appointment slot with settings other than the default and save
      3. Attempt to edit that single appointment slot

      Instead of the slot's settings page having retained the saved values, they are all reset to default.

      This is more of an annoyance than anything. If you are trying to change just one of the variables within the slot's settings, you must take care to remember the other settings or else you risk creating appointments with the wrong information!

        Activity

        Henning Bostelmann added a comment -

        Hello Tony,

        I didn't manage to reproduce the bug as described. However, I found the following behaviour: When one clicks on "Add slot", then changes some default values, but leaves the "Teacher" field empty, and clicks "Save", then the form is re-displayed with an error message (expected) and all fields are reset to their default value (NOT expected).

        This bug is now fixed on github. Does this resolve your problem?

        Henning

        Tony Box added a comment -

        Henning,

        When I do the process outlined, I found that the only value which doesn't "stick" is the DATE value.
        It appears that the rest of the settings do stay.

        Combined with the bug which you described, however, this is even more of a problem. For example:

        A teacher adds a new scheduler slot, fills in all information, and writes a detailed comment. They save it and everything is good. Then, they go back to edit the comment they wrote and didn't notice that the date had reverted to default (January 18th 2012 in my install, for some reason) and they click "Save". They now get an error message saying that you can't create a scheduler slot for a date in the past and the whole form is reset (the bug you described), deleting their comment.

        I'm using the newest version in your git repo.

        Thanks,
        Tony

        Tony Box added a comment -

        The date reverting to default seems to happen any time you open up a slot to edit.

        I just tried to manually schedule a student, which brings up the same edit slot form and requires you to hit "save", and ran into the same problem.

        Tony

        Henning Bostelmann added a comment -

        Not sure - I can't reproduce that on my end.

        However, there was recently a bug in Moodle core that made most date selectors misbehave (specifically, it was the Month field that was always reset to January), see MDL-28352. That bug affected Scheduler as well; it has been fixed in January this year. Is your core Moodle up-to-date to that level, or might it be that the fix is not yet in your local Moodle installation?

        Tony Box added a comment -

        Ahh, good look. That seems like it might fix our problem since we are on 2.1.1.

        I haven't got the time right now, but when I do, I'll upgrade on our dev server and see if the problem still exists and then report back here.

        Thanks,
        Tony

        Henning Bostelmann added a comment -

        As said above, I assume that MDL-28352 has resolved the problem - let me know if not.

        Henning Bostelmann added a comment -

        Closing all resolved scheduler issues that had no activity in the past month.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development