Add-ons
  1. Add-ons
  2. CONTRIB-3608

Regression: Brocken Layout borders in header offset,

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.2
    • Fix Version/s: 2.4
    • Component/s: Theme: Rocket
    • Labels:
      None
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Rank:
      39504

      Description

      Since version 2012041704 the borders and alignments of several divs are broken with firefox (see attached screenshots) and chrome. I didn't test IExplorer. I couldn't find the relevant css code.

        Activity

        Hide
        Dave Jäckel added a comment -

        The correct layout with rocket theme 2012032400

        Show
        Dave Jäckel added a comment - The correct layout with rocket theme 2012032400
        Hide
        Dave Jäckel added a comment -

        The broken layout of rocket theme 2012041704 and upwards with firefox on linux (same result with chrome).
        The red background goes down to far, wrongly visible border between zone 4 and 5, banner image goes to far to the right.
        <nothing changed except code replacement between the two screenshots.

        Show
        Dave Jäckel added a comment - The broken layout of rocket theme 2012041704 and upwards with firefox on linux (same result with chrome). The red background goes down to far, wrongly visible border between zone 4 and 5, banner image goes to far to the right. <nothing changed except code replacement between the two screenshots.
        Hide
        Julian Ridden added a comment -

        Thanks for the report.

        I have tested in Safari, Firefox and Chrome and cannot replicate your issue.

        Can you try two things for me.

        1. Go to the Rocket theme settings and change the banner height. Does that fix the issue?
        2. Make sure you go to development and "purge all caches". It may be that the old style has been cached by Moodle.

        Let me know how you go.

        P.S. This theme remains untested in IE. It works in ALL standards compliant browsers however

        Julian

        Show
        Julian Ridden added a comment - Thanks for the report. I have tested in Safari, Firefox and Chrome and cannot replicate your issue. Can you try two things for me. 1. Go to the Rocket theme settings and change the banner height. Does that fix the issue? 2. Make sure you go to development and "purge all caches". It may be that the old style has been cached by Moodle. Let me know how you go. P.S. This theme remains untested in IE. It works in ALL standards compliant browsers however Julian
        Hide
        Dave Jäckel added a comment -

        I've changed the banner heights to different values, but it didn't help. The (by default red) background is still to far down.
        I've purged all caches as you suggested, but it didn't help either. Theme developing mode is on. I'm on a moodle 2.2.2+, build date of last friday.
        You can have a look yourself if you want. I will send you the URL by private.

        Dave

        Show
        Dave Jäckel added a comment - I've changed the banner heights to different values, but it didn't help. The (by default red) background is still to far down. I've purged all caches as you suggested, but it didn't help either. Theme developing mode is on. I'm on a moodle 2.2.2+, build date of last friday. You can have a look yourself if you want. I will send you the URL by private. Dave
        Hide
        Darren Sutton added a comment -

        Hi Julian,

        This is a great theme and I've been able to use it to do some really nice things but I have the same issue. I have followed all the steps above as well but its not resolved the problem. Using Firefox, safari and chrome. You can take a look at our site at: vle.nlcsjeju.kr

        Cheers,

        Darren

        Show
        Darren Sutton added a comment - Hi Julian, This is a great theme and I've been able to use it to do some really nice things but I have the same issue. I have followed all the steps above as well but its not resolved the problem. Using Firefox, safari and chrome. You can take a look at our site at: vle.nlcsjeju.kr Cheers, Darren
        Hide
        Dave Jäckel added a comment -

        I've pulled the 1.2 branch from git and tested this version. I now get the new edit mode indicator. But the layout is still not correct. The logo is slightly displayed to far right when not at the startpage (without pushing the menu to the right, but overlapping).
        Are you sure the right code is published?
        Is there anything I can do to help finding the bug?

        Show
        Dave Jäckel added a comment - I've pulled the 1.2 branch from git and tested this version. I now get the new edit mode indicator. But the layout is still not correct. The logo is slightly displayed to far right when not at the startpage (without pushing the menu to the right, but overlapping). Are you sure the right code is published? Is there anything I can do to help finding the bug?
        Hide
        Dave Jäckel added a comment -

        Updated to Moodle 2.2.3+ and latest git-code for Rocket, and the layout seems to be o.k. now.
        Issue can be closed, I think.

        Show
        Dave Jäckel added a comment - Updated to Moodle 2.2.3+ and latest git-code for Rocket, and the layout seems to be o.k. now. Issue can be closed, I think.
        Hide
        Julian Ridden added a comment -

        Fixed some time back but forgot to close this item. Doing so now.

        Show
        Julian Ridden added a comment - Fixed some time back but forgot to close this item. Doing so now.

          People

          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development