Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-3625

Sorry, but you do not currently have permissions to update calendar event erro ehn upgrading mod_hotpot

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.2
    • Fix Version/s: 2.0.9, 2.1, 2.2, 2.3
    • Component/s: Module: HotPot
    • Labels:
      None
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE, MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE

      Description

      Similar to MDL-32630 but for mod_hotpot, when upgrading to 2.2 from 1.9 I get the following error:

      Sorry, but you do not currently have permissions to update calendar event

      More information about this error
      Stack trace:

      line 435 of /lib/setuplib.php: moodle_exception thrown
      line 2009 of /calendar/lib.php: call to print_error()
      line 1440 of /mod/hotpot/lib.php: call to calendar_event->update()
      line 1305 of /mod/hotpot/lib.php: call to hotpot_update_events()
      line 656 of /mod/hotpot/db/upgrade.php: call to hotpot_refresh_events()
      line 540 of /lib/upgradelib.php: call to xmldb_hotpot_upgrade()
      line 271 of /lib/upgradelib.php: call to upgrade_plugins_modules()
      line 1437 of /lib/upgradelib.php: call to upgrade_plugins()
      line 269 of /admin/index.php: call to upgrade_noncore()

      I believe this is due to the bug in MDL-32631

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  1/Jul/11