Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-3696

Questionnaire module reports undefined capability mod/questionnaire:addinstance in 2.3dev

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 2.3
    • 2.3
    • Module: Questionnaire
    • None
    • MOODLE_23_STABLE
    • MOODLE_23_STABLE

    Description

      Questionnaire module reports undefined capability mod/questionnaire:addinstance when run under Moodle 2.3dev

      Debugging shows:
      The module questionnaire does not define the standard capability mod/questionnaire:addinstance
      line 3438 of /course/lib.php: call to debugging()
      line 1899 of /course/lib.php: call to course_allowed_module()
      line 1774 of /course/lib.php: call to get_module_metadata()
      line 139 of /blocks/site_main_menu/block_site_main_menu.php: call to print_section_add_menus()
      line 700 of /blocks/moodleblock.class.php: call to block_site_main_menu->get_content()
      line 232 of /blocks/moodleblock.class.php: call to block_list->formatted_contents()
      line 929 of /lib/blocklib.php: call to block_base->get_content_for_output()
      line 981 of /lib/blocklib.php: call to block_manager->create_block_contents()
      line 352 of /lib/blocklib.php: call to block_manager->ensure_content_created()
      line 5 of /theme/aardvark_postit/layout/general.php: call to block_manager->region_has_content()
      line 765 of /lib/outputrenderers.php: call to include()
      line 712 of /lib/outputrenderers.php: call to core_renderer->render_page_layout()
      line ? of unknownfile: call to core_renderer->header()
      line 1416 of /lib/setuplib.php: call to call_user_func_array()
      line 98 of /index.php: call to bootstrap_renderer->__call()
      line 98 of /index.php: call to bootstrap_renderer->header()

      Is this an installation upgrade issue in 2.2.3 (Build - 20120511) ?

      I note that the version number has not been changed between this latest build and the previous one (although the file version.php has been amended), and hence no upgrade is forced. Is this as intended.

      Many thanks. Questionnaire is a brilliantly useful module!

      Attachments

        Issue Links

          Activity

            People

              rezeau Joseph Rézeau
              jwhite10 John White
              Mike Churchward
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                25/Jun/12