Add-ons
  1. Add-ons
  2. CONTRIB-3796

The template NEWMODULE is not compatible with Moodle 2.3

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Critical Critical
    • Resolution: Unresolved
    • Affects Version/s: 2.3.1
    • Fix Version/s: None
    • Component/s: Module: Newmodule
    • Labels:
      None
    • Affected Branches:
      MOODLE_23_STABLE
    • Rank:
      42906

      Description

      I wanted to get all informations about the ability mod/NEWMODULE:addinstance and the other new settings for an activity module but the template is too old and not compatible with Moodle 2.3. Please make an update for the template NEWMODULE and the documentation. What must be done to update a module for Moodle 2.3?

        Activity

        Hide
        David Mudrak added a comment -

        Hi Ralf. Thanks for reporting this. You're right, the template needs a refresh. Meanwhile, please refer to https://github.com/moodle/moodle/blob/master/mod/upgrade.txt for all required changes in activity modules. Same file can be found for other plugin types as well and it contains valuable information for plugin developers.

        Show
        David Mudrak added a comment - Hi Ralf. Thanks for reporting this. You're right, the template needs a refresh. Meanwhile, please refer to https://github.com/moodle/moodle/blob/master/mod/upgrade.txt for all required changes in activity modules. Same file can be found for other plugin types as well and it contains valuable information for plugin developers.
        Hide
        David Mudrak added a comment -

        Added Damyon as a watcher as he might be interested in this.

        Show
        David Mudrak added a comment - Added Damyon as a watcher as he might be interested in this.

          People

          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:

              Development