Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-4144 META: Code checker 1Q 2014 round
  3. CONTRIB-4149

Add some 3rd part sniffs about PHP 5.3/5.4/5.5 deprecated stuff

    XMLWordPrintable

Details

    • Sub-task
    • Resolution: Fixed
    • Minor
    • 2.3.5, 2.4.2
    • 2.3.4, 2.4.1, 2.5
    • Local: Code checker
    • None
    • MOODLE_23_STABLE, MOODLE_24_STABLE, MOODLE_25_STABLE
    • MOODLE_23_STABLE, MOODLE_24_STABLE

    Description

      It would be great to add some rules available out there:

      http://techblog.wimgodden.be/2012/03/04/php-5-4-compatibility-checks-using-php_codesniffer/

      Controlling that we are not using stuff declared as deprecated in different versions of PHP.

      Move them to be part of the Moodle standard and have them tested.

      Ciao

      Attachments

        Activity

          People

            stronk7 Eloy Lafuente (stronk7)
            stronk7 Eloy Lafuente (stronk7)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Clockify

                Error rendering 'clockify-timesheets-time-tracking-reports:timer-sidebar'. Please contact your Jira administrators.