Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-5158

Enable the codechecker to run phpcompatibility sniffs for a given PHP version

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Minor
    • Resolution: Deferred
    • Affects Version/s: 2.7
    • Fix Version/s: None
    • Component/s: Local: Code checker
    • Labels:
      None
    • Affected Branches:
      MOODLE_27_STABLE

      Description

      Since MDLSITE-2800, the phpcompatibility standard supports passing a given PHP version ("--runtime-set testVersion X.Y.Z") and that produces multiple sniffs (deprecated, removed, non-existing... function/classes) to be run specifically for that version.

      This is about to enable the codechecker UI to, optionally, specify a PHP version to run the phpcompatibility sniffs against.

      The basic idea is to show all versions between:

      1) the required @ admin/environment.xml for current site.
      2) the current php version being used.

      And to allow the developer to pick one (can default to 1).

      Note: This should be supported both by the web UI and the run.php CLI script.

      That is, ciao

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              moodle.com moodle.com
              Reporter:
              stronk7 Eloy Lafuente (stronk7)
              Participants:
              Component watchers:
              moodle.com, Eloy Lafuente (stronk7)
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: