Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-5292

Preferences/Change password throws error for non-enrolled students

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Deferred
    • Affects Version/s: 2.7.1
    • Fix Version/s: None
    • Component/s: Theme: Essential
    • Labels:
      None
    • Plugin Version:
      2.7.7 (Build: 2014090303)
    • Affected Branches:
      MOODLE_27_STABLE

      Description

      Using Moodle 2.7.1+ (Build: 20140829) and Essential theme 2.7.7 (Build: 2014090303).
      Preferences/Change password throws error for students not enrolled in any course on the moodle site!

      You are trying to use an invalid course ID
      Debug info:
      Error code: invalidcourseid
      Stack trace:
      line 463 of \lib\setuplib.php: moodle_exception thrown
      line 59 of \login\change_password.php: call to print_error()

        Attachments

          Activity

            People

            Assignee:
            gb2048 Gareth J Barnard
            Reporter:
            rezeau Joseph Rézeau
            Participants:
            Component watchers:
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: