Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-6069

Questionnaire Moodle 3.0 PHP 7.0.1 broken

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0, 3.1
    • Fix Version/s: 3.0, 3.1
    • Component/s: Module: Questionnaire
    • Labels:
      None

      Description

      With the latest version of Moodle 3.0 with PHP 7 support (this week's release), Questionnaire causes entire courses to not load (just display a blank page). This is completely breaking Moodle 3.0. This is in the error log:

      [Fri Dec 18 14:05:07.856205 2015] [fcgid:warn] [pid 8260:tid 13576] [client x,x,x,x:52812] mod_fcgid: stderr: PHP Fatal error: 'break' not in the 'loop' or 'switch' context in C:\\Apache24\\htdocs\\moodle\\mod\\questionnaire\\questiontypes
      questiontypes.class.php on line 297, referer: https://moodleaddress/moodle/course/index.php?categoryid=2

        Attachments

          Activity

            People

            • Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                16/Nov/15