Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9, 1.9.1, 1.9.2
    • Fix Version/s: None
    • Component/s: Patch: LSU gradebook
    • Labels:
      None
    • Environment:
      Requires php5
    • Database:
      Any
    • Affected Branches:
      MOODLE_19_STABLE
    • Rank:
      22355

      Description

      Latest documentation can be found at: http://docs.moodle.org/en/grade/report/simple_grader/index

      Please let us know what we can do to make this system better.
      Install instructions follow.

      A full featured simple grader report requires the simple tree, anonymous grade block, a slight modification to the existing theme's header.html, and a slight modification to lib/grade/grade_item.php.

      • Once the simple grader has been installed, editing the header.html should consist of adding the following lines in the 'head' element:

      <?php $filenamejs = "$CFG->dirroot/grade/report/simple_grader/lib/menufixer.php";
      if (file_exists($filenamejs))

      { include($filenamejs); }

      ?>

      • The modification in grade_item.php is simply changing:

      var $aggregationcoef = 0;

      to:

      var $aggregationcoef = 1;

      • Add a check for Simple Grader report to gradelib, located in {MOODLE_ROOT}/lib/gradelib.php:

        At the very beginning of the function grade_regrade_final_grade, you must add code that calculates core modules correctly. So, the code below must be added right under the function declaration line which looks something like:

        function grade_regrade_final_grades($courseid, $userid=null, $updated_item=null) {
        // Check for Simple Grader Report
        global $CFG;

        $exists = file_exists($CFG->dirroot. '/grade/report/simple_grader/lib/simple_gradelib.php');
        if ($exists) { require_once($CFG->dirroot . '/grade/report/simple_grader/lib/simple_gradelib.php'); return simple_grade_regrade_final_grades($courseid, $userid, $updated_item); }

        * Add a similar check in {MOODLE_ROOT}

        /grade/import/lib.php around line 55 in function grade_import_commit add the following:

      $use_function = false;
      $file = $CFG->dirroot . '/grade/report/simple_grader/lib/simple_gradelib.php';
      if (file_exists($file))

      { require_once($file); $use_function = true; }

      Then jump to around line 82:

      ....
      // insert each individual grade to this new grade item
      foreach ($grades as $grade) {
      if ($use_function){
      if(!simple_update_final_grade($grade->userid, $gradeitem, 2, $grade->finalgrade, 'import', $grade->feedback, FORMAT_MOODLE))

      { $failed = true; break 2; }


      } else if (!$gradeitem->update_final_grade($grade->userid, $grade->finalgrade, 'import', $grade->feedback, FORMAT_MOODLE))

      { $failed = true; break 2; }


      }

      And lastly around line 125:

      ....
      // make the grades array for update_grade
      foreach ($grades as $grade) {
      if (!$importfeedback)

      { $grade->feedback = false; // ignore it }


      if ($use_function){
      if(!simple_update_final_grade($grade->userid, $gradeitem, 2, $grade->finalgrade, 'import', $grade->feedback))

      { $failed = true; break 2; }


      } else if (!$gradeitem->update_final_grade($grade->userid, $grade->finalgrade, 'import', $grade->feedback))

      { $failed = 1; break 2; }


      }

      • Denying access to the original grader report. Fortunately, this can be done in Moodle, defining capabilities.

      With the Site Administration block navigate to Users->Permissions->Define Roles. For every role, change the gradereport/grader:view to "Not Set"

      This will deny access to the original gradebook.

      Note: in order to get help files to make sense in the simple tree, make sure that the help files location in simple_tree/lang/en_utf8/help/grade/ are moved into core.

      1. CONTRIB-738.diff
        542 kB
        Anthony Borrow
      2. LSU_gradebook.diff
        527 kB
        Anthony Borrow
      3. LSU_gradebook.diff
        527 kB
        Anthony Borrow
      1. import_mymathlab.png
        109 kB
      2. quick_edit.png
        178 kB

        Activity

        Anthony Borrow added a comment -

        Robert - I think rather than asking folks to make changes to the theme files it would be better to just make them for the user. While some of this patch is plugin like (adding the block), other parts of it are a patch so for now I think we should treat the whole thing as a patch. I'm working on doing the install and will try to generate a good patch file. Peace - Anthony

        Anthony Borrow added a comment -

        Looking at /grade/import/lib.php you give a line number (around line 55) but it would be helpful to specifically say where to insert the function (I am assuming it is after the line:

        global $CFG, $USER;

        and before:

        $commitstart = time(); // start time in case we need to roll back

        Using a patch file will hopefully simplify all of this for users. As I looked at the code, it indicates that it should check if the file exists and if so require it, should there be an error or some type of notification if the file does not exist or do you think it is sufficient to just rely on the $use_function variable?

        Anthony Borrow added a comment -

        Just a little logical question, "around line 82 " in the /grade/import/lib.php file you have:

        // insert each individual grade to this new grade item
        foreach ($grades as $grade) {
        if ($use_function){

        I'm just wondering for performance why not do the if statement first and avoid stepping through the grades and running the check for $use_function. It's probably an insignificant performance gain and more theoretical than practical but I figured I would ask the question.

        Anthony Borrow added a comment -

        Disregard the last comment, I see what is happening now.

        Anthony Borrow added a comment -

        Robert - Here is a diff file which I think could be used against 1.9 that should make all of the changes mentioned in your INSTALL instructions. A system admin should be able to apply the patch, go to notifications and enable extra grade features for the Grade Features block and then unset the gradebook in the roles and be done with it. Could you check to ensure that I've not overlooked anything and that this works as intended. Just out of curiosity, why is the block filename and tables anonymous_grade but the block name Grade Features? Not a big deal if they are different it just caught my attention. Peace - Anthony

        Anthony Borrow added a comment -

        You will also notice that I added comments just to make it easy to search for modified sections of the code. I tried to be consistent and use LSU gradebook either after the change of an individual line or around sections of modified code.

        Anthony Borrow added a comment -

        Robert - Here is a first attempt at a zip file that could be extracted to the user's latest 1.9 with pre-patched version of the file. In other words, this and the diff file is what we would ideally start with in CVS. I was thinking of LSU_gradebook but am open to suggestions on what you would prefer it to be called. I'm looking at placing it in contrib/patches. Peace - Anthony

        Anthony Borrow added a comment -

        p.s. - I removed all the svn and DStore files that were in the original zip but I went through creating the zip file pretty quickly so it may be worth checking to see if I may have overlooked something. Peace - Anthony

        Robert Russo added a comment -

        We are abandoning the javascript based theme changes to move to a grade/lib.php change. Some instructors figured out how to get to the old tree I will take your code, make the changes and re-upload.

        Philip Cali added a comment -

        This modified gradebook abandons the javascript changes. There are instructions in INSTALL.txt in order to make the change permanent.

        Anthony Borrow added a comment -

        Philip - Could you clarify what you mean by there are instructions in INSTALL.txt to make the change permanent? I'm not sure what change you are talking about? Also, I noticed that when using quickedit I received: Notice: Undefined property: stdClass::$itemtype in /home/arborrow/Moodle/code/contrib-738/grade/report/simple_grader/quick_edit_table.php on line 89. To get rid of it I simply replaced the line with:

        if (!empty($this->data['interest']>itemtype) and $this>data['interest']->itemtype != 'manual') {

        so that the first check is to see if it is not empty so since it fails it moves on without evaluating the second comparison; however, if there is a value then it will check to make sure it is not manual.

        Peace - Anthony

        Anthony Borrow added a comment -

        I was curious why the user pics were different sizes - it could just be something strange about my setup like it could not find the images because I copied the database over but not the data files. I would still find the different sizes to be strange.

        Anthony Borrow added a comment -

        Here is the diff file that I think we should add to contrib/patches/LSU_gradebook/LSU_gradebook.diff. This will allow folks to use the diff file to patch their system without being overly sensitive (at least in theory) to the version of Moodle 1.9 that they are using. The auto-generated zip file will include the diff along with the actual files; however, there is always the need to keep those files updated with the latest changes made in core which can be somewhat of a chore when a fairly active file is patched. Peace - Anthony

        Anthony Borrow added a comment -

        Just to comment on how I created the LSU_gradebook.diff file. I started by doing a 19STABLE branch download from CVS using one of the mirrors and then copying the files from the zip file you attached in the tracker. Then I ran create patch in Eclipse. It should be fairly easy to keep things updated but each time we change a file we should probably regenerate and update the LSU_gradebook.diff as well.

        Anthony Borrow added a comment -

        Import mymathlab readme indicates to copy the lang file gradeimport_mymathlab.php to the lang/en_utf8 file. This is not necessary and for the sake of keeping things more modular I would recommend placing it in /grade/import/mymathlab/lang/en_utf8. In addition, I noticed that in the /grade/import/mymathlab/index.php file there were get_strings for file and update that were using the gradeimport_mymathlab.php lang file rather than just using the definitions in moodlelib.php. I see no reason to duplicate those strings and would just you get_string('file') rather than get_string('file','gradeimport_mymathlab'). Let me know if that makes sense. Peace - Anthony

        Anthony Borrow added a comment -

        Updating the diff file with the mymathlab lang files moved and the extry !empty check mentioned earlier.

        Anthony Borrow added a comment -

        One final comment before we commit - I think it is important that on files that we are patching that we have a comment clearly indicating from which version the file was merged. While the recommended way of installing will be to use the patch, others may opt to simply copy all of the files including the patched ones. Alternatively, we could make the install process two part. Copy the new files on the system and then run the patch. The disadvantage is that users now familiar with how to apply a patch will be asking for the patched files. The down side is that if we provide the patched files we may have to content with some versioning issues; however, my experience with the GBPv2 patch was that these are minimal and I always stuck to the line that if the user was making use of the patch that they were using the latest version - so in the case of the LSU_gradebook patch we would assume 1.9+. But before I committed all the files I figured it would be best to check with you and see how you wanted to handle this since you will be the ones maintaining it. Peace - Anthony

        Philip Cali added a comment -

        The latest update comes with a Linux-style path that you can use to patch Moodle core, as opposed to doing manual code changes.

        The command is (which is also mentioned in the updated INSTALL.txt):
        cd

        {MOODLE_ROOT}; patch -p0 <{MOODLE_ROOT}

        /grade/report/simple_grader/gradebook.patch

        Anthony Borrow added a comment -

        Robert - OK - Just to make sure we are all on the same page. I would like to get this committed this week if possible. Using the LSUgradebook_prepatched_10_18_08.zip file that Philip uploaded, it is my understanding that that file only contains new files (plugin-like) and that all of the patches are in the gradebook.patch file. I do not understand why that was placed so far down in the tree. Why not put the patch file in root so that folks do not have to go looking for it and store it in

        {MOODLE_ROOT}

        ? For maintaining the files, have you made a determination of how you want to maintain the patched files? Personally, I like the idea of requiring folks to apply the patch; however, that will limit the number of folks who make use of it. Alternatively, modified files could be provided but it is important to keep track of the version that is provided and then to patch those up as needed so it is more work from a maintainers perspective. For now, I'm thinking of moving the patch file to the root directory with the blocks and grade folders and adding it all to contrib/patches. Another possible approach would be to have everything in one patch file as I mentioned earlier. Then there is only one file to maintain. Just let me know how you want to proceed and then we can knock this out. Peace - Anthony

        Philip Cali added a comment -

        Hey Anthony,

        I moved the patch file to the root. I agree with you, this is a better spot. As far as maintaining, working with a single patch file makes sense for us.

        Anthony Borrow added a comment -

        Philip - Excellent, looks good. The only thing missing in that root path s the INSTALL.txt or a README.txt file with installation instructions. I can upload without it and then we can use creating it in CVS as a test to verify privileges. To apply for access you (and/or Robert) will go to http://moodle.org/cvs. I did not hear any objection to calling this the LSU_gradebook patch but if you would prefer a different name just let me know. Also, just to be clear, it looks like the latest file you uploaded was a hybrid of new files and one patch file. By a single patch file, I was quite literally referring to something like LSU_gradebook.diff file. So once you confirm for me the name of the folder is OK and whether you want to use the 'hybrid' approach or the single patch file I will get it uploaded. Thanks for your attention to these details as I want to make sure we get it right from the start. Don't hesitate to let me know if you have any question. Peace - Anthony

        Philip Cali added a comment -

        Anthony - We feel better about the hybrid approach: leaving the core changes to the patch file and the new files for the actual gradebook. We have verified that the core changes patch works for 193 stable. LSU_gradebook is a fine enough name for us. Thank you for being patient with us.

        Anthony Borrow added a comment -

        Philip - The patience has gone both ways, I appreciate your flexibility and willingness to help me get things ready for the initial commit. A couple other comments. Similar to the patch file, I think the README.txt and INSTALL.txt should be in the root folder. Also, a minor point in the /import/mymathlab and /import/smart folders there is a file called README. Any objection to renaming those README.txt as it helps to avoid ambiguity about the file type? I can resolve these pretty easily but wanted to check with you before I hit the commit button. Peace - Anthony

        Philip Cali added a comment -

        Anthony - I moved the INSTALL.txt to the root, along with the patch. I change added the .txt's to the end of the names of the README's in the importers so we'd be consistent. I added a function in the gradebook, and some lines to the patch. I think we're finally ready!

        Anthony Borrow added a comment -

        Philip - Agreed, I think we are ready to commit. I'll get to it a little later this afternoon. Peace - Anthony

        Anthony Borrow added a comment -

        moving to component Patch: LSU gradebook

        Anthony Borrow added a comment -

        Robert and Philip - I need one or both of you to apply for CVS write access for contrib/patches/LSU_gradebook. I've added the code to CVS at http://cvs.moodle.org/contrib/patches/LSU_gradebook/ and the auto generated zip file should be available within 24 hours. Once you submit your CVS write requests I can approve them and you will be able to maintain the code there. I have also created a component in the tracker that can be used to manage this project and bumped Robert's privileges so that he can manage those issues. All issues related to the Patch: LSU gradebook component will automatically be assigned to to Robert. If we need or want to change that just let me know. Similarly, with CVS if other folks need access just have them apply at http://moodle.org/cvs. I typically use the project lead (which is Robert) to confirm all such additions but there is no reason why multiple folks cannot be involved and have access so feel free to manage this in a way that makes life easy for all. Just let me know how I can be of help and thanks again for your generosity in sharing your work with the larger Moodle community. Peace - Anthony

        Anthony Borrow added a comment -

        I am going to go ahead and resolve this as we are just waiting for the moodle.org/cvs requests. Peace - Anthony

        Anthony Borrow added a comment -

        Robert - I have approved your CVS write access to contrib/patches/LSU_gradebook which contains all of the folders you mentioned in the CVS write request. Let me know if you need anything else. Peace - Anthony

        Anthony Borrow added a comment -

        Now that Robert Russo has CVS access, I'm going to go ahead and close this issue. Feel free to comment here in the tracker if anything else is need in reference to this patch. Thanks again Robert to you and your staff for your fine work. Peace - Anthony


          People

          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development