Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-7539

mod_game privacy api bug

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.5.3
    • Fix Version/s: None
    • Component/s: Module: Game
    • Labels:
      None
    • Plugin Version:
      2018112101
    • Affected Branches:
      MOODLE_35_STABLE

      Description

      I have updated to the latest version of mod_game, when trying to approve privacy requests I get the following error:

      "Beim Aufruf von mod_game\privacy\provider::get_contexts_for_userid ist ein Fehler aufgetreten. Das Plugin mod_game hat die Verarbeitung der Daten nicht beendet. Unten finden Sie Informationen für den Pluginentwickler.

      Argument 2 passed to core_privacy\local\request\contextlist::add_from_sql() must be of the type array, none given, called in /[...]/mod/game/classes/privacy/provider.php on line 135"

        Attachments

          Activity

            People

            Assignee:
            bdaloukas Vasilis Daloukas
            Reporter:
            rschrenk Robert Schrenk
            Participants:
            Component watchers:
            Vasilis Daloukas
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: