Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-7557

Questionnaire 3.5.2 (only?) no longer compatible with Moodle 3.5.2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.5.2
    • Fix Version/s: 3.5.3
    • Component/s: Module: Questionnaire
    • Labels:
      None

      Description

      Hello,

      It seems that Questionnaire 3.5.2 (only ?) is not compatible with (earlier?) Moodle 3.5.2 builds (before Moodle version 2018050800) that contain the older admin privacy tool (2018051415 instead of 20180514114 ?

      Unfortunately, I cannot upgrade my site to 3.5.3 yet, while my tests of Questionnaire 3.5.2 did not detect errors, so I recently also upgraded the production, and - as I have now discovered - I am faced with a non-fuctional Plugin privacy registry page, which goes blank while the debugger only throws this error:

      Fatal error: Interface 'core_privacy\local\request\core_userlist_provider' not found in /ocfs2/www/owko/mod/questionnaire/classes/privacy/provider.php on line 30

      I wonder if any simple backward compatibility could be provided. I wish Moodle had stopped me from upgrading if it was know 2018050800 was the core version required for the newer Questionnaire versions to work...

       

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                12/Nov/18