Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-7646

Flashcard Fatal Error on legacy_plugin_cron_task execution

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.5.3
    • Fix Version/s: None
    • Component/s: Module: Flashcard
    • Labels:
    • Plugin Version:
      2019011000
    • Affected Branches:
      MOODLE_35_STABLE

      Description

      “Legacy cron processing for plugins (core\task\legacy_plugin_cron_task)” error when flashcard cron is executed.

       

      PHP Fatal error: Declaration of mod_flashcard\privacy\provider::delete_data_for_all_users_in_context(core_privacy\local\request\deletion_criteria $criteria) must be compatible with core_privacy\local\request\core_user_data_provider::delete_data_for_all_users_in_context(context $context) in http/mod/flashcard/classes/privacy/provider.php on line 28

       

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: