Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-7696

Adminer doesn't launch well with some themes

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.5.5
    • Fix Version/s: 3.5.5, 3.6.3
    • Component/s: Local: Adminer
    • Labels:
      None
    • Plugin Version:
      3.5 (2019040700)
    • Affected Branches:
      MOODLE_35_STABLE
    • Fixed Branches:
      MOODLE_35_STABLE, MOODLE_36_STABLE

      Description

      Several people encounter problems with Adminer, that doesn't launch well, depending of the theme you use.

      Problems reported with Adaptable, and i also have it with Essential and More (at least).

      In Adminer plugin comments, Ruthine Burton wrote about this problem in november, and Christian Bocquet wrote about a solution in april :

      to make this plugin compatible with the Adaptable or Essential theme, try to remove lines 56 and 57 from the templates/adminer.mustache file:
      56 require(['theme_boost/modal']);
      57 require(['theme_boost/loader']);

      I think it's worth investigate. Thanks in advance.

        Attachments

          Activity

            People

            Assignee:
            grabs Andreas Grabs
            Reporter:
            fox Séverin Terrier
            Participants:
            Component watchers:
            Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              11/Mar/19