Uploaded image for project: 'Plugins'
  1. Plugins
  2. CONTRIB-8338

Moodle Adminer connects a differnt DB than that of Moodle...

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.10
    • Fix Version/s: None
    • Component/s: Local: Adminer
    • Labels:
      None
    • Plugin Version:
      3.4 (2018042100)
    • Affected Branches:
      MOODLE_310_STABLE

      Description

      Hi,

      Because of customers (belong to the public sector0 I have to maintain older version (3.3) of Moodle with older PHP (5.6.40) and MySQL (5.7)...

      As on the same server I also have newer (3.10) version of Moodle with newer PHP (7.4) and MySQL (8.0) I have several installs of all the components...

      MySQL 8.0 installed directly on the machine, and 5.7 is inside a Docker container...

      In Moodle the DB defined with localhost:3306 and 127.0.0.1:3310 respectively...

      Moodle has no problem and each instance work with the correct DB...

      The problem is with Adminer...

      Moodle reports that the MySQL is 

      database mysql (5.7.32) version 5.5.31 is required and you are running 5.7.32

      but Adminer reports this (and show the wrong MySQL)

      MySQL version: 8.0.22-0ubuntu0.20.04.3 through PHP extension MySQLi

      Notice that the MOODLE version NOT correct as 3.3 not in the list...

        Attachments

          Activity

            People

            Assignee:
            grabs Andreas Grabs
            Reporter:
            kepeter Peter Eliyahu Kornfeld
            Participants:
            Component watchers:
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated: