Moodle
  1. Moodle
  2. MDL-10028

Bulk messaging not available for teachers

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.8.4, 1.9, 2.0
    • Component/s: Messages
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      Teachers who wish to bulk message students (i.e. open Participants, select all users, then select "With selected users" drop-down box) are not given the option. However, administrators are given the option.

        Gliffy Diagrams

          Issue Links

            Activity

            James Ballard added a comment -

            We notice a similar situation whereby teachers trying to bulk message participants receive the following error:

            'Sorry, but you do not currently have permissions to do that (Read all messages on site)'

            However, when you check the role definitions teachers are allowed to bulk message via the following capability:

            Send a message to many people
            moodle/course:bulkmessaging

            Switch the following to allow from not set for teachers seems to provide solution, but is it the intention to allow teachers to have this access (risks seem pretty low in most contexts):

            Read all messages on site
            moodle/site:readallmessages

            Joseph Rézeau added a comment -

            This is a major bug, still not corrected in latest 1.8.2 version to-date.

            What is needed here is to have the possibility for teachers to bulk e-mail their students EVEN WITH messaging disabled at Security ? Site policies level.

            See this discussion : http://moodle.org/mod/forum/discuss.php?d=81229

            This bug does not exist in 1.7 but it exists in 1.8 and 1.9.

            It is related to MDL-10112, but the solution given there is not satisfactory...

            Joseph

            Joseph Rézeau added a comment -

            Can someone please fix this bug as soon as possible?
            Joseph

            Martin Dougiamas added a comment -

            Yes, looks like there's a problem with the old messaging on/off switch still hanging around and confusing the issue.

            How about we fix it according to Yu's suggestion which is:

            $CFG->messaging OFF means off for all. Messaging disabled. (I think this is the case now)

            $CFG->messaging ON means messaging is enabled, and can be further controlled by capabilities.

            moodle/site:sendmessage - added to the authenticated user and teacher roles by default, for normal message sending
            moodle/course:bulkmessage - added to the teacher roles by default

            And Joseph can turn off the first one if he likes.

            Joseph Rézeau added a comment -

            Hi Martin,
            My comments to your suggestion:

            How about we fix it according to Yu's suggestion which is:

            $CFG->messaging OFF means off for all. Messaging disabled. (I think this is the case now)
            --> OK
            $CFG->messaging ON means messaging is enabled, and can be further controlled by capabilities.

            moodle/site:sendmessage - added to the authenticated user and teacher roles by default, for normal message sending
            this capability does not exist at the moment in 1.8.2... Do you mean that it would be a new capability to be added ... from moodle 1.8.4 only?

            moodle/course:bulkmessage - added to the teacher roles by default

            And Joseph can turn off the first one if he likes.

            I have not choice, $CFG->messaging is set to OFF by our admin

            What I really need (urgently for this academic year) is the pre-roles situation, i.e. to have both these settings:
            $CFG->messaging OFF
            and
            moodle/course:bulkmessage - available to teacher roles by default
            I hope that will be possible soon,
            Joseph

            Nicolas Martignoni added a comment -

            I agree with Joseph. This is a feature regression and is missing a lot here too.

            Martin Dougiamas added a comment -

            I do believe that having a switch called "messaging off" with the help "Should the messaging system between site users be enabled?" should do what it says.

            It seems obvious to me that the people who implemented this feature and ignored that setting in 1.6 actually created a bug. If teachers are sending messages then students have to receive them, which means they need to use the messaging interface (popups). People are sending messages to each other even though the admin said all messaging should be off. That's a bug.

            I do hear what you are saying, and I understand you want to send messages of some kind to students. (I really hope you aren't using this to send messages to ALL students because you should be using a forum for that).

            So, how about we do it like this:

            Three controls:

            CFG->messaging - on/off at site level
            moodle/site:sendmessage - added to the authenticated user and teacher roles by default, for normal message sending (dependent on above setting)
            moodle/course:bulkmessage - added to the teacher roles by default, controls the bulk messaging display (independent of above settings)

            Even if the site messaging is off, it would STILL allow bulkmessage to work, however this would now inform you in the interface that you are sending EMAILS to the students directly instead of using the messaging system (because Moodle messaging has been disabled).

            If site messaging is on, then bulkmessage could allow you to choose to send your message via Moodle messaging OR direct email.

            Note that in all cases email should respect the "do not send email" setting in the profile.

            How does that sound?

            We could do that in 1.8 and 1.9.

            Art Lader added a comment -

            It would be great if this were fixed. It's something that several teachers in my area are asking for.

            Ray Lawrence added a comment -

            Please see MDL-10294 for issues with the emails sent.

            Just a quick thought on adding site:sendmessage as default to authenticated user. A potential (albeit gloomy) scenario:

            Messaging turned on
            Self registration allowed
            Someone creates account - is authenticated user
            Spams using messaging

            Joseph Rézeau added a comment -

            Martin D. > So, how about we do it like this:
            >Three controls:
            > CFG->messaging - on/off at site level
            > moodle/site:sendmessage - added to the authenticated user and teacher roles by default, for normal message sending (dependent on above >setting)
            > moodle/course:bulkmessage - added to the teacher roles by default, controls the bulk messaging display (independent of above settings)
            >Even if the site messaging is off, it would STILL allow bulkmessage to work, however this would now inform you in the interface that you are sending >EMAILS to the students directly instead of using the messaging system (because Moodle messaging has been disabled).
            >If site messaging is on, then bulkmessage could allow you to choose to send your message via Moodle messaging OR direct email.
            >Note that in all cases email should respect the "do not send email" setting in the profile.
            >How does that sound?
            >We could do that in 1.8 and 1.9.
            ------------------------------------------------
            Thanks Martin, this looks exactly what I need.
            It's quite OK to me for bulkmessaing to send e-mails to the students rather than using the Moodle messaging system (which I never use anyway).

            Of course I know that I have to use a forum to send e-mail to all students enrolled in a moodle course (or to a group).
            What I want to use is different, I want to be able to go to an Activity Report, check those students who have not yet done the activity, select them and use the drop-down list at the bottom to do With selected users->Add/Send Message to send a "circular" bulk message to those specific students only. This is really indispensable to my teaching.

            Hope you can find a workable solution for Moodle 1.8 very soon.
            ATB
            Joseph

            Nicolas Martignoni added a comment -

            Yes, Martin this would do it
            Cheers and thanks!

            Martin Dougiamas added a comment -

            OK, go for it Yu!

            Yu Zhang added a comment -

            Thanks for the report guys, code in cvs please test/report problems.

            Cheers,

            Yu

            Nicolas Martignoni added a comment -

            Thanks Yu, the feature works correctly on 1.9beta2.

            Reopening, because the string "Messaging is disabled on this site, emails will be sent instead" is hardcoded in file user/messageselect.php.

            Joseph Rézeau added a comment -

            Works fine for me (tested in 1.8 and 1.9). At last! Thanks.
            I confirm the language problem mentioned by Nicolas.
            Joseph

            Yu Zhang added a comment -

            Should be fixed now, thanks. Also turned the messaging block off if $CFG->messaging is off.

            Nicolas Martignoni added a comment -

            Fixed indeed. Many thanks, closing.


              People

              • Votes:
                13 Vote for this issue
                Watchers:
                11 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: