Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9
    • Component/s: Calendar
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      Calendar view changes

      See attached document

      Discussion thread: http://moodle.org/mod/forum/discuss.php?d=73365

        Gliffy Diagrams

        1. Calendar_view_changes.doc
          181 kB
          Derek Woolhead
        1. moodle.org.admin.jpg
          247 kB

          Activity

          dougiamas Martin Dougiamas added a comment -

          It seems this went ahead in HEAD. Can this bug be closed then?

          derekw Derek Woolhead added a comment -

          Resolved as fixed for 1.9. Is there likely to be any testing? if not can be updated to closed

          dougiamas Martin Dougiamas added a comment - - edited

          Hi, Derek.

          Next time can you flesh out the descriptions properly on the tracker as different bugs rather than a word document. This patch seems to have clumped a whole lot of changes together without any discussion about the merits of each one.

          This in particular worries me:

          "4. Single Course events on/off key will be replaced by up to three course event keys including applicable course shortnames. If the user has more than three courses then some of the colours and on/off switches will be reused i.e. red = CF101, CF104; green=CF102; blue=CF103. The number 3 could be discussed or made easily alterable in software, we chose it because 99.4% of our students are on 3 or fewer courses."

          I've attached a screenshot for how the "put courses randomly into three categories" approach looks for me as admin on moodle.org (pretty terrible). There must be a better way for all of us who are not an OU student

          dougiamas Martin Dougiamas added a comment -

          To be more explicit, the problems are this:

          • the courses seem to be randomly divided into three different colours with no clear reason. The effect for most people is a bewildering array of colours that means nothing at all.
          • the course names are shown as NUMBERS after the first four
          • the hide/show buttons for each one of the course colours actually acts on all three

          IMO, this is a big step backward in usability AND accessibility. I would revert this immediately while we look for a better way to achieve what you aiming for.

          Perhaps we need to add a section in the calendar preferences where each user can manually choose a colour for each of their courses.

          dougiamas Martin Dougiamas added a comment -

          Yu, can you please revert just the bit that divides the courses into three buttons/colours, and return it to a single button with one colour for all "my courses". In HEAD, obviously.

          derekw Derek Woolhead added a comment -

          When I made the changes back in June, admin users could not display all events for all courses, as in my opinion, that is ridiculous anyway, as there was no distinction between any course events at all, so you had absolutely no idea what courses the events related to. As an admin user, you displayed events for a particular course by selecting the course from the drop down list

          With regard to course names, it is the course shortname that is displayed. You get the course id's if there are no course shortnames.

          Pity nobody has been paying any attention to calendar, as there were quite a few other issues that were also fixed, and nobody at all has responded to the proposed changes, in the bug tracker and in the forum, until now.

          dougiamas Martin Dougiamas added a comment -

          Well, that's why I suggested documenting the issues separately. A lot was hiding in this little bug here.

          Most of the changes were great, thank you. The problem is just this one aspect.

          lazyfish Yu Zhang added a comment -

          Reverted, courses filter back to the old one and color back to the old scheme as well.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                3/Mar/08