Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-10087

Can't edit current dataset in calculated question

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8, 1.8.1
    • Fix Version/s: None
    • Component/s: Questions
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE

      Description

      User can't edit current dataset in calculated question. When I edit question system always prompt to create NEW dataset (private or shared)

        Gliffy Diagrams

          Activity

          dlnsk Dmitry Pupinin added a comment -

          Maybe it helps...
          In question2.php on step 2 of editing:

          Notice: Undefined property: dataset in Z:\home\moodle.test\v18\question\type\datasetdependent\abstractqtype.php on line 365
          Warning: Invalid argument supplied for foreach() in Z:\home\moodle.test\v18\question\type\datasetdependent\abstractqtype.php on line 343
          Notice: Undefined property: dataset in Z:\home\moodle.test\v18\question\type\datasetdependent\abstractqtype.php on line 366
          Warning: array_flip(): The argument should be an array in Z:\home\moodle.test\v18\question\type\datasetdependent\abstractqtype.php on line 366

          ppichet Pierre Pichet added a comment -

          I cannot reproduce it on my instalation

          http://132.208.141.198/moodle_18/
          so try it user:moodle pw:moodle
          I have set the debug level to developper so I should see the same warnings.
          Do a new CVS on your installation .

          ppichet Pierre Pichet added a comment -

          I found the problem something like form->dataset and form->datasets elsewhere. I will correct it tonight

          ppichet Pierre Pichet added a comment -

          The same problem has been reproted by Stefan Eberhard see
          http://moodle.org/mod/forum/discuss.php?d=73647
          The problem exits with Moodle 1.8 but not with Moodle 1.6 although the abstracttype and questiontype files are similar.
          I will explore how the HTML Quick Form could be implied...

          ppichet Pierre Pichet added a comment -

          Finally this was due to mispelt $form->datasets and $form->dataset.
          remove $form->datasets and add & to $form in
          function preparedatasets(&$form , $questionfromid='0'){ line 210

          see http://moodle.org/mod/forum/discuss.php?d=73647

          CVS done on 1.8 and will be done soon on other versions after retesting.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: