Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-10102

User posts and forum widgets are rendering outside of the intended content area

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.1
    • Fix Version/s: 1.9
    • Component/s: HTML Editor (TinyMCE)
    • Labels:
      None
    • Environment:
      moodle.org (1.8+ ? unknown version of moodle)

      Description

      User posts for the forum module need some adjustments. Either it is not properly cleaned on input or not properly cleaned on output

      As you can see at the following location:
      http://moodle.org/mod/forum/discuss.php?d=50154

      The following post ID's are problematic:
      http://moodle.org/mod/forum/discuss.php?d=50154#p328921
      http://moodle.org/mod/forum/discuss.php?d=50154#p328924

      Notice that some of the content is rendering outside of the post

        Attachments

          Activity

            People

            Assignee:
            skodak Petr Skoda
            Reporter:
            jgraham Jeff Graham
            Tester:
            Nobody
            Participants:
            Component watchers:
            Andrew Nicols, Dongsheng Cai, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              3/Mar/08