Moodle
  1. Moodle
  2. MDL-10112

bulk messaging fails silently when messaging not enabled

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.1
    • Fix Version/s: 1.8.1
    • Component/s: Messages
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      To reproduce the bug:

      1. assign to a teacher the bulkmessaging and readallmessage capabilities (if not already assigned)
      2. disable the messaging system
      2. login as teacher, enter the participant list in a course, select one or more participant then Send a message to selected people using the drop down list.
      3. Enter a message, then click preview
      4. Once in preview, click send.
      5. Moodle claims the message has been sent, while it has not since the Messaging is disabled.

        Gliffy Diagrams

          Activity

          Yu Zhang added a comment -

          should be fixed now, this option is hidden when messaging is disabled.

          Joseph Rézeau added a comment -

          Solution not satisfactory, see MDL-10028.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: