Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-10122

Search Courses form does not complies with WAI AA and Section 508

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.1
    • Fix Version/s: 1.8.2, 1.9
    • Component/s: Course
    • Labels:
      None
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      When displaying a combo list in the Moodle home page, the search form at the bottom of the page is not valid WAI AA and US 508:

      [WAI 12.4 (AA), US-508-n] Associate form controls with <label> tags using the 'id' attribute:
      <input type="text" size="12" name="search" alt="Search courses" value="" />
      <input type="submit" value="Search courses" />

        Gliffy Diagrams

          Activity

          lazyfish Yu Zhang added a comment -

          Hi Andrea,

          Which combo list are you referring to? I can not find a combo list in the course search form. I also tried using the validator on your homepage too but it passed all xhtml strict checks. Can you attach a screenshot or give me the exact url?

          Cheers,

          Yu

          andreabix Andrea Bicciolo added a comment -

          Sorry Yu, my explanation is not very clear: for combo list I'd mean the format of the home page. Combo list is the home page format dysplaying categories and course titles.

          Andrea

          lazyfish Yu Zhang added a comment -

          Hi Andrea,

          The format is used on your test site http://www.mtouch.it/mdl18/, right? I ran the validator through it and the result is ok. Sorry I don't really understand what the issue is.

          Cheers,

          Yu

          andreabix Andrea Bicciolo added a comment -

          Hello Yu, yes it validates using the W3C validator, but the AA and Section 508 Issue still remains. Please try the Total Validator Plugin for Firefox.

          Cheers,
          Andrea

          lazyfish Yu Zhang added a comment -

          Hi Andrea,

          Should be fixed now, please check, thanks!

          Cheers,

          Yu


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                8/Jul/07