Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-10227

Update overwrites Non en-utf8 langfiles

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 1.9
    • Fix Version/s: None
    • Component/s: Administration, Language
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE

      Description

      While updating in 1.9 moodle updates automatically the non en langfiles if the admin is logged in with an other lang than en without requests. We've lost several new translations in the german lang pack.

      Verwaltung der Sprachpakete: de_utf8 ...
      Aktualisiere Moodle-Datenbank von Version 1.9 dev (2007060100) auf 1.9 dev (2007062008)...

        Gliffy Diagrams

          Issue Links

            Activity

            skodak Petr Skoda added a comment -

            Hi, this is IMO expected behavior - only _local packs and extra lang dirs in moodle directory are not touched during upgrade.
            Workaround for translator should be IMHO to place the lang pack that is being translated into moodle/lan/xx directly, not into moodledata or _local

            Assigning to david, please review my proposed solution and fix the translation docs if needed, thanks!

            ralfh Ralf Hilgenstock added a comment -

            Hi Petr,

            there should be buttons "Update all language packages" and "Skip update language packages". There are lots of installations that didn't make changes in the local language package. Its the first process with an automatic change of files in the moodledata folder. This is an unexpected behaviour for most admins.

            ralfh Ralf Hilgenstock added a comment -

            Petr, during the update existing files are deleted. In this moment also files from additional blocks and mods are deleted. Thats an other problem.

            timhunt Tim Hunt added a comment -

            Perhaps a good compromise would be to make a zip-file copy of the language file directory in moodledata before updating it.

            Either Moodle can do that, or we could just put instructions in the release notes.

            skodak Petr Skoda added a comment -

            The files in moodle/lang/* are not deleted, only lang files in moodledata are updated/deleted.
            I would not recommend the skipping of lang pack updates because it might cause trouble during upgrade.

            Maybe we could do following:
            1/ prevent editing of langpacks in moodledata folder, allow editing of only _local versions - needs docs changes + coding changes
            2/ do trastations in moodle/lang folder - needs docs changes
            3/ add zip backup when updating lang packs - some coding required

            mina Nicolas Martignoni added a comment -

            Seems that this issue is related (or even duplicate?)

            mudrd8mz David Mudrak added a comment -

            IMHO the biggest problem is that an admin is not warned BEFORE her moodledata/lang/* is overwritten. It would be nice and OK to put another screen into the upgrade wizard with this warning together with "Continue" button. If admin knows there are local changes, she can back up and restore manually. This is not critical as it is only lang pack maintainers' issue.

            And yes - this is apparently duplicate of MDL-8330

            mudrd8mz David Mudrak added a comment -

            See comments in duplicated issue.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: