Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-10273

students view the calendar "New event" button, but event is not saved due to lack of capability

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.1
    • Fix Version/s: 1.8.1
    • Component/s: Calendar
    • Labels:
      None
    • Environment:
      Moodle 1.8.1 migtrated from a 1.6.x . DB UTF8
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE

      Description

      to reproduce the bug:
      1. as teacher, add a calendar block
      2. now logoff and login as student enrolled in the above course
      3. as student, try to add a user event
      4. Moodle allows student to edit a new user event with all the needed parameters
      5. now clicking "save", Moodle returns an error "you are not allowed to do this", due to lack of student's capability.

      If the student does not have such clendar capability by default, the New event button should not be available. Otherwise, enable this capability by default in the student legacy role.

        Gliffy Diagrams

          Attachments

            Activity

            lafayettenuke Kenneth Newquist added a comment -

            I can't reproduce this issue. I'm using Moodle 1.8.1(2007021510) migrated from Moodle 1.7.1

            lazyfish Yu Zhang added a comment -

            Hi Andrea, thanks, should be fixed now so that users with no permission will not see the "New Event" button.

            lazyfish Yu Zhang added a comment -

            Hi to reproduce this you will need to have moodle/calendar:manageownentries set to inheirt for the "Authenticated user" role.

            andreabix Andrea Bicciolo added a comment -

            Thanks Yu. Tested and all seems working ok.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  11/Jun/07