Moodle
  1. Moodle
  2. MDL-10722

Add one environmental check to be able to announce the min required Moodle version before update

    Details

    • Type: New Feature New Feature
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.2, 1.9
    • Fix Version/s: 1.8.4, 1.9
    • Component/s: Installation
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      Until now we haven't performed any check between Moodle versions. But it's possible that, in the future, we have some restrictions like:

      "In order to upgrade to Moodle 2.0 you need to be running, at least, Moodle 1.9"

      Currently nothing in environmental checks is able to run this tests. And I think it could be a good idea to add it to as many versions as possible.

      Ciao

        Gliffy Diagrams

          Activity

          Hide
          Eloy Lafuente (stronk7) added a comment -

          I've committed to HEAD (1.9) one new version of lib/environmentlib.php that is able to:

          • On install, nothing.
          • On upgrade (or from admin), check for current and target Moodle versions to decide if the upgrade can be performed.
          • If the required version is undefined, it defaults to 1.0

          Also I've updated admin/environment.xml to make Moodle 1.9 mandatory for Moodle 2.0.

          So, now, feel free to:

          • Backport both changes to as many versions as you want (1.7 and 1.8 should be enough).
          • Delete or modify the requirement I've added in the xml file if it isn't ok.

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - I've committed to HEAD (1.9) one new version of lib/environmentlib.php that is able to: On install, nothing. On upgrade (or from admin), check for current and target Moodle versions to decide if the upgrade can be performed. If the required version is undefined, it defaults to 1.0 Also I've updated admin/environment.xml to make Moodle 1.9 mandatory for Moodle 2.0. So, now, feel free to: Backport both changes to as many versions as you want (1.7 and 1.8 should be enough). Delete or modify the requirement I've added in the xml file if it isn't ok. Ciao
          Hide
          Séverin Terrier added a comment -

          Seems good in 1.8.3 and 1.9 beta 3 (and from long time ago) : could probably be closed.

          Show
          Séverin Terrier added a comment - Seems good in 1.8.3 and 1.9 beta 3 (and from long time ago) : could probably be closed.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Thanks for feedback. Closing now. Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Thanks for feedback. Closing now. Ciao

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: