Moodle
  1. Moodle
  2. MDL-10767

New Window setting "Allow the window to be scrolled" resets

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.2
    • Fix Version/s: 1.8.7, 1.9.3, 2.0
    • Component/s: SCORM
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE, MOODLE_20_STABLE

      Description

      On the Updating SCORM/AICC page, select "Display package in New Window" and uncheck all checkboxes except "Allow the window to be resized." Save changes. Later, Update this SCORM/AICC and you will see that the "Allow the window to be scrolled" checkbox is checked. You must once again uncheck this box, or your window will have scrollbars!

      There are also three missing language strings on the Updating SCORM/AICC page:

      [[activation]]
      [[options]]
      [[updatefreq]]

        Gliffy Diagrams

          Activity

          Beatriz Beltran added a comment -

          PLEASE DO SOMETHING ABOUT THIS. MY TEACHERS ARE GOING CRAZY HAVING TO EDIT ALL THEIR OLD RESOURCES! (more than a million)

          This behavior has the same problem in all Resources, meaning text pages, web pages,etc.

          When upgrading to 1.8.2 all old resources that were programmed only to:
          Allow the window to be resized
          Allow the window to be scrolled

          Are now set back to all the window attributes checked. However they still work fine.

          BUT, when editing a resource, all the attributes show checked out. If the attributes are not unchecked the window goes back to show Menu bar, tools bar, etc.

          Is any place where the administrator can set those attributes a default to use throughout the system?
          Would that be nice or what?

          Beatriz Beltran added a comment -

          Going to Site Administration, Modules, Activities, Resources, Settings it is possible to change what windows attributes should be available by default.

          This seems to solve our problem.

          The problem is the lack of documentation!

          Dan Marsden added a comment -

          John/Beatriz - can we close this, or are there still missing strings?

          thanks,

          Dan

          John Isner added a comment -

          Dan,
          The missing strings seem to be fixed, BUT the window issues are still unresolved. (I just tested on demo.moodle.org).

          Dan Marsden added a comment -

          thanks. - will have a look at it!

          Dan

          Dan Marsden added a comment -

          ok taking notes.....

          it seems like at some point all those options were to be stored in the mdl_scorm > options field - instead of having a field for each value in the scorm table.. - don't know enough about formslib to see how that might work...

          also the variables seem to be set as $SCORM_POPUP_OPTIONS in locallib.php (but not 'grabbed' from anywhere) so even if we were saving the values somewhere in the db, it isn't checking them.

          there also seems to be some code at the top of locallib that doesn't seem to serve any purpose (stdoptions isn't used anywhere)

          $stdoptions = '';
          foreach ($SCORM_POPUP_OPTIONS as $popupopt => $value) {
          $stdoptions .= $popupopt.'='.$value;
          if ($popupopt != 'status')

          { $stdoptions .= ','; }

          }

          Dan Marsden added a comment -

          attaching patch that should fix this.

          Dan Marsden added a comment -

          fix now in 1.8stable, 1.9stable and HEAD

          Piers Harding added a comment -

          code reviewed and discussed.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: