Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-10811

A pagename of wiki chages from anyone to 'group' after restoring backuped wiki contents which does not contain user datas.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.2
    • Fix Version/s: 1.8.6, 1.9.1
    • Component/s: None
    • Labels:
      None
    • Database:
      Any
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      Cause of this problem is probably careless miss.
      mod/wiki/backuplib.php, in function wiki_backup_one_mod(),

      //Start mod
      fwrite ($bf,start_tag("MOD",3,true));
      //Print assignment data
      fwrite ($bf,full_tag("ID",4,false,$wiki->id));
      fwrite ($bf,full_tag("MODTYPE",4,false,"wiki"));
      fwrite ($bf,full_tag("NAME",4,false,$wiki->name));
      fwrite ($bf,full_tag("SUMMARY",4,false,$wiki->summary));
      fwrite ($bf,full_tag("PAGENAME",4,false,$wiki->wtype)); <-- Here!
      fwrite ($bf,full_tag("WTYPE",4,false,$wiki->wtype));

      fwrite ($bf,full_tag("PAGENAME",4,false,$wiki->wtype));
      -> fwrite ($bf,full_tag("PAGENAME",4,false,$wiki>pagename));

      This problem will not appear when you restore wiki contents which contain user datas.

        Attachments

          Activity

            People

            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                15/May/08