Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-10833

Moodle ignores course theme for several course admin pages

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.2, 1.9
    • Fix Version/s: 1.8.3, 1.9
    • Component/s: Themes
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE

      Description

      Moodle ignores the course theme and uses the site theme to display several course administration pages.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              urshunkler Urs Hunkler added a comment - - edited

              A list shown for which course admin page Moodle wrongly uses the site theme:

              Settings - site_theme
              Assign roles - course_theme
              Grades - course_theme
              Groups - course_theme
              Backup - site_theme
              Restore - course_theme
              Import - site_theme
              Reset - site_theme
              Reports - site_theme
              Questions - course_theme
              Files - course_theme

              urshunkler Urs Hunkler added a comment -

              In Moodle 1.6 all course admin pages were displayed correctly with the course theme.

              dougiamas Martin Dougiamas added a comment -

              I've fixed these in Moodle 1.9 ... can someone else backport them to 1.8 (and 1.7 probably, the issue is related to the roles changes)

              dougiamas Martin Dougiamas added a comment -

              Merged all fixes to 1.8 stable myself

              rezeau Joseph Rézeau added a comment -

              Re-opening issue.
              The problem of reverting to site theme still occurs

              • in Moodle 1.8.2+ for
                Admin -> Reports Live logs from the past hour and all other logs in general
              • in Moodle 1.9 for
                Admin -> Reports Live logs from the past hour only
                I would be really grateful for a quick fix of this behavior on 1.8.2.

              Joseph

              rezeau Joseph Rézeau added a comment -

              Problem persists also in 1.8.2+ in Admin -> Restore and Admin -> Backup
              Joseph

              skodak Petr Skoda added a comment -

              all reported places should be fixed in cvs (the Backup worked fine for me in 1.8x)

              thanks for the report

              rezeau Joseph Rézeau added a comment -

              Problem still not fixed... See MDL-11039

              rezeau Joseph Rézeau added a comment -

              Problem stil not fixed for individual student's Activity Report.
              Petr, can you please fix this as soon as possible.
              Also maybe linked problem in individual student's Activity Report is non-sticky forced language for actual course, reported in MDL-11584
              Thanks
              Joseph

              dougiamas Martin Dougiamas added a comment -

              Fixed activity reports and blogs as well.


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Oct/07