Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-10906

No option in user profile ot specify local drive for local files

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.2
    • Fix Version/s: 1.9.9
    • Component/s: Resource
    • Labels:
      None
    • Environment:
      any
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      To reproduce:

      Enable linking to local files - Modules > Activities > resources
      Go to course, link to local file.
      go to user profile
      No option to set local drive as described:
      "Each participant is able to choose their own local path for such files, by editing their user profile."

        Gliffy Diagrams

        1. 20100826_MDL-10906_1.9.patch
          18 kB
          Rossiani Wijaya
        2. 20100827a_MDL-10906_1.9.patch
          18 kB
          Rossiani Wijaya
        3. 20100827b_MDL-10906_2.0.patch
          0.9 kB
          Rossiani Wijaya

          Activity

          skodak Petr Skoda added a comment -

          Confirming the local files are partially broken and not much maintained for a long time, it is also not compatible with linux.

          ray Ray Lawrence added a comment -

          Where do we go with things like this? I don't use it, but if it's part of core it should work... even if there are limitations.

          skodak Petr Skoda added a comment -

          There are several unfinished and unmaintained parts in core moodle, I hope there will be enough time to fix all these problems in 1.9.x

          btw I was already working on this about a year ago, but gave up after an hour - if I remember it corrected I thought it needs some more cleanup+bugfixing to make it work properly

          dougiamas Martin Dougiamas added a comment -

          I thought this was broken in most browsers now anyway (due to security restrictions).

          dougiamas Martin Dougiamas added a comment -

          Helen, could you please make sure this feature is removed from help files and other places?

          ray Ray Lawrence added a comment -

          Would be best it was just removed completely. Is this to be the case?

          tsala Helen Foster added a comment -

          Yes, it will be removed completely. As Martin mentions, it doesn't work on most browsers, including recent versions of IE.

          tsala Helen Foster added a comment -

          Reassigning to Rosie, who has kindly agreed to remove:

          1. the resource_allowlocalfiles setting in Site Admin > Modules > Activities > Resource
          2. the functionality to add a local file in the add a resource 'Link to a file or website'

          I'm assuming the setting doesn't exist in HEAD as the resource module has been completely rewritten, so this issue should be fixed in 1.9.8+ only.

          rwijaya Rossiani Wijaya added a comment -

          Adding Sam to watcher.

          Create patch to remove the functionality to add a local file.

          Sam,
          When you have a chance, could you take a look the patch and let me know if I upgrade the DB correctly.

          Thanks
          Rosie

          samhemelryk Sam Hemelryk added a comment -

          Hi Rosie,

          Thanks for the patch, everything looks good however there are a couple of changes you should make.

          1. The upgrade code shouldn't go in the main upgrade.php, resource being a module it should really go in mod/resource/db/upgrade.php (bumb the version in the mod/resource/version.php as well).
          2. Within the upgrade code you don't need to check the setting exists before calling unset_config, you can call it regardless.

          Other than that everything worked fine.
          I'm not 100% sure what the mod/resource version should be bumped to, you should probably check with Martin regarding that.

          Cheers
          Sam

          rwijaya Rossiani Wijaya added a comment -

          Post updated patch for 1.9 and 2.0

          rwijaya Rossiani Wijaya added a comment -

          commit patches to 1.9 stable and 2.0.


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                8/Jun/10