Moodle
  1. Moodle
  2. MDL-10922

During Install, missing image place holders for docs.gif

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.3
    • Fix Version/s: 1.9
    • Component/s: Installation
    • Labels:
      None
    • Environment:
      NuOnce CentOS v4.5 Final with BlueQuartz v4.7 with PHP v4.4.7 and MySQL v4.1.20 on Apache 2
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE
    • Rank:
      28690

      Description

      Moodle v1.8.2+ Nightly Tarball on 20th Aug 2007 downloaded and installed on a BlueQuartz Appliance.
      Install folder: http://www.domain.com/moodle
      In the file moodle/install.php there are many references to
      $INSTALL['wwwrootform'] . '/pix/docs.gif'
      During Install, on the step that checks the PHP.INI settings, we get missing image place holders for docs.gif .
      It is searching as http://www.domain.com/pix/docs.gif instead of http://www.domain.com/moodle/pix/docs.gif
      As a temporary workaround I copied the pix folder to the docroot as well.

        Activity

        Hide
        WebBiz added a comment -

        On Lines 597, 604, 611, 618 in moodle/install.php, I have replaced:-

        echo '<img src="' . $INSTALL['wwwrootform'] . '/pix/docs.gif' . '" alt="Docs" class="iconhelp" />';

        with

        echo '<img src="pix/docs.gif' . '" alt="Docs" class="iconhelp" />';

        This can be a fix - please check it out.

        Show
        WebBiz added a comment - On Lines 597, 604, 611, 618 in moodle/install.php, I have replaced:- echo '<img src="' . $INSTALL ['wwwrootform'] . '/pix/docs.gif' . '" alt="Docs" class="iconhelp" />'; with echo '<img src="pix/docs.gif' . '" alt="Docs" class="iconhelp" />'; This can be a fix - please check it out.
        Hide
        Petr Škoda added a comment -

        Fixed in cvs, thanks for the report and patch

        Show
        Petr Škoda added a comment - Fixed in cvs, thanks for the report and patch

          People

          • Assignee:
            Petr Škoda
            Reporter:
            WebBiz
            Tester:
            Nobody
            Participants:
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: