Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-11015

tag->descriptionformat hasn't a default value...

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9
    • Component/s: General
    • Labels:
      None
    • Environment:
      mysql
    • Database:
      Any
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      ... and insertion of new tags can fail.

      Under mysql, I'm getting this when inserting new tags in my user profile:

      Field 'descriptionformat' doesn't have a default value

      INSERT INTO mdl_tag ( USERID, NAME, RAWNAME, TAGTYPE, TIMEMODIFIED ) VALUES ( 2, 'dog', 'dog', 'default', 1188230145 )

      • line 1450 of lib/dmllib.php: call to debugging()
      • line 46 of tag/lib.php: call to insert_record()
      • line 368 of tag/lib.php: call to tag_create()
      • line 452 of tag/lib.php: call to tag_an_item()
      • line 59 of user/editlib.php: call to update_item_tags()
      • line 119 of user/editadvanced.php: call to useredit_update_interests()

      Folowing guidelines... a proper format should be provided... I guess it's the MOODLE_FORMAT one.... Ciao

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  3/Mar/08