Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-11061

SSL Publishing a Moodle site with ISA Server and no SSL Bridging (Browser--ssl--> ISA Server --nonssl --> Moodle) breaks Quiz View

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.8.2
    • Fix Version/s: 2.0
    • Component/s: Libraries
    • Labels:
      None
    • Environment:
    • Affected Branches:
      MOODLE_18_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      I'll try to describe my config as best as possible.

      -When a browser connects to https://my.org/moodle ISA Server retreives pages from the internal site known to it as http://my.org/moodle
      cfg$->wwwroot =https://my.org/moodle
      -Moodle in general works great under this configuration
      -You can create quizzes and add questions, however once questions are added and you try to preview the quiz you receive the following error:

      /* begin error */
      Page class mapping requested for unknown type: http:--webmail.brsd.ab.ca-moodle-mod-quiz-view line 100 of lib\pagelib.php:

      call to debugging() line 65 of lib\pagelib.php:
      call to page_map_class() line 50 of lib\pagelib.php:
      call to page_create_object() line 51 of mod\quiz\view.php:
      call to page_create_instance()

      Notice: Undefined index: http:--webmail.brsd.ab.ca-moodle-mod-quiz-view in C:\moodle\wwwroot\moodle\lib\pagelib.php on line 103
      Notice: Undefined index: http:--webmail.brsd.ab.ca-moodle-mod-quiz-view in C:\moodle\wwwroot\moodle\lib\pagelib.php on line 104

      Page class mapping for id "http:--webmail.brsd.ab.ca-moodle-mod-quiz-view" exists but class "" is not defined line 104 of lib\pagelib.php:

      call to debugging() line 65 of lib\pagelib.php:
      call to page_map_class() line 50 of lib\pagelib.php:
      call to page_create_object() line 51 of mod\quiz\view.php:
      call to page_create_instance()

      Notice: Undefined index: http:--webmail.brsd.ab.ca-moodle-mod-quiz-view in C:\moodle\wwwroot\moodle\lib\pagelib.php on line 107

      Fatal error: Class name must be a valid object or a string in C:\moodle\wwwroot\moodle\lib\pagelib.php on line 67

      /* end error */

      Workarounds:
      1. Disable ISA SSL connection for the external https://my.org/moodle (not desirably since we want all traffic encrypted) and change cfg$-->wwwroot=http://my.org/moodle
      2. Enable SSL Bridging in ISA so that ISA retreives https://my.org/moodle (not desirable as is puts ssl load on moodle server), this is a little more difficult because you need to export the ssl cert from apache and then import it into the Trusted Certificate Store on the ISA Server. this can be done by using the following command: bin/openssl pkcs12 -export -in server.crt -inkey server.key -out server.p12 (of course adjusting the command line to point to correct paths of the files.

      The problem I beleive lies in the pagelib.php as it does not seems to be construting the pagetype correctly for quiz view in this environment but it does appear to do it properly for other pagetypes since I can not reproduce the problem in any other module.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Votes:
                  5 Vote for this issue
                  Watchers:
                  14 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    24/Nov/10