Moodle
  1. Moodle
  2. MDL-11155

should we add a column to the question list table to show the author of a question??

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 2.0
    • Component/s: Questions, Quiz
    • Labels:
      None
    • Affected Branches:
      MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_20_STABLE

      Description

      Could we add a column to the question list table to show the original author of a question?? This would be helpful for the question creation module. Would also add a item to the 'sortby' drop down to allow sorting by author.

        Gliffy Diagrams

          Issue Links

            Activity

            Jamie Pratt added a comment -

            What do you think Tim?

            Pierre Pichet added a comment -

            Given that students or others than the course teacher could be allowed to create questions with the new category code, the author should be displayed if necessary by adding an additional button like the one for displaying the question text and effectively sorting by author can be usefull.

            Tim Hunt added a comment -

            Why are we doing sort-by as a dropdown. It would be better to do it by clicking the column headings, like everywhere else in Moodle - if you are getting your hands dirty here. I know it has been like that forever.

            The issue is, of course, space. Basically, this would halve the space available for the question name. Probably that is OK. Most questions seem to have quite short names.

            Finally, on the question bank screen. Why is it displayed in such a narrow column in the middle of the screen. It is actually wider on the quiz editing page!

            So basically, yes, go for it.

            Jamie Pratt added a comment -

            Decided I don't really need this right now for the question creation module.

            Tim Hunt added a comment -

            Fixed as part of the work on MDL-16345.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: