Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-11242

HTML too large for message compose window

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.2, 1.9
    • Fix Version/s: 1.9
    • Component/s: Messages
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE, MOODLE_19_STABLE
    • Fixed Branches:
      MOODLE_19_STABLE

      Description

      With HTML Editor on for messaging, the message compose window is too small to hold the HTML Area editor and the Send Message button,

      The HTMLArea widget is too wide, and overflows to the right. The send button appears too low on the frame, and requires scrolling down to press.

      Clearly visible on 1.8.x and HEAD (1.9). On Moodle v1.6 the sizes were correct – and quite pleasant to use.

      This is on Firefox 2.0.0.6 Windows.

        Gliffy Diagrams

          Issue Links

            Activity

            dougiamas Martin Dougiamas added a comment -

            Yeah this has been annoying me too. I had a quick look into it but I couldn't make it smaller ... I wonder if it's related to XHTML or something like that.

            dougiamas Martin Dougiamas added a comment -

            OK, found it now and fixed in 1.9. Cheers!

            martinlanghoff Martín Langhoff added a comment -

            This fix broke "fullscreen" htmlarea on IE6/7. Under IE the width is "100%" and we inconditionally append "px" to that.

            Comitting the fix into 18/19/HEAD...

            martinlanghoff Martín Langhoff added a comment -

            Committed - Now... to clean my hands after having touched the horrible MS Script Debugger!

            sbourget Stephen Bourget added a comment -

            Tested in both IE 6 and IE7
            Closing...

            smithrn Ryan Smith added a comment -

            I just updated the 1.9 branch and this is fixed. Doesn't look like the fix was committed to the MOODLE_18_STABLE branch, thus, I'm still having the problem in Firefox.

            martinlanghoff Martín Langhoff added a comment -

            Oops! Sorry about that. The fix for the subsequent FF breakage is now on 18_STABLE too.

            If lib/editor/htmlarea/htmlarea.php v1.16.2.5 does not fix the problem for you, reopen this bug with a good steps-to-repro, so I can see it. As far as I could test today, with that fix htmlarea is working fine on FF v2.0 and IE6/7 both on the normal window and on the fullscreen.

            smithrn Ryan Smith added a comment -

            I just grabbed the latest from CVS and the issue is fixed for me on MOODLE_18_STABLE.

            scyrma Mathieu Petit-Clair added a comment -

            The change made in htmlarea.php breaks the htmlarea window in IE7/Vista.

            scyrma Mathieu Petit-Clair added a comment -

            I am reverting to the too-large window for 1.9, as the current setting breaks the htmleditor in every other case. This will also make the htmleditor show the same behavior in 1.8 and 1.9.

            scyrma Mathieu Petit-Clair added a comment -

            The fix for MDL-12726 seems to re-fix this.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  3/Mar/08