Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-11343

Hidden role assignment at site showing in participants list

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not a bug
    • Affects Version/s: 1.8, 1.8.1, 1.8.2
    • Fix Version/s: None
    • Component/s: Roles / Access
    • Labels:
      None
    • Affected Branches:
      MOODLE_18_STABLE

      Description

      Custom role that includes capability moodle/course:view
      Role assigned at site level to user (hidden assignment)
      User shows up in participant list for every course

        Gliffy Diagrams

          Issue Links

            Activity

            ikawhero Shane Elliott added a comment -

            Should have checked first before opening this bug - see MDL-8441

            carolinemoore Caroline Moore added a comment -

            This is a completely separate problem from MDL-8441. Please re-open it!

            This is a major problem for me. I have several custom roles that are assigned at the System level. They need to be able to view all courses (e.g. my User Support colleagues, the Disability Services office) but they should absolutely not show up on the Participants list of every course, even to Teachers. This drives my faculty crazy, understandably: suddenly they are seeing an extra dozen users in their Participants list!

            I am currently getting around this problem by assigning the System-level roles as "hidden assignments" and setting the capability moodle/course:viewhiddenassigns to Prevent. However, this means my faculty cannot use hidden assignments within their courses.

            I would recommend adding a capability to choose whether or not a particular role should show up in the Participants lists of courses.

            tdejager Tiffany Morgan added a comment -

            I would also request this be reopened. We have student coaches, TAs, and parents whom need access to view the course, but are in no way participants.

            mike1989 Mike Worth added a comment -

            This is caused by course:view being taken to mean that the user is enrolled in the course; it can only be fixed by making course:view and course:enrolled separate

            tsala Helen Foster added a comment -

            Please see my forum reply http://moodle.org/mod/forum/discuss.php?d=120556&parent=538288#p538558 for a possible workaround to this issue.

            websterb Bruce Webster added a comment -

            We had a problem with teachers being surprised seeing all these extra (system-assigned) people when going into participants.

            Hiding them altogether I felt was not the best solution as we like transparency - teachers should know who can look into their course.

            My fix which I've just come up with is very simple - change one default value near the top of the moodle/user/index.php file...

            change
            $roleid = optional_param('roleid', 0, PARAM_INT);
            to
            $roleid = optional_param('roleid', $CFG->defaultcourseroleid, PARAM_INT);

            I think it is entirely justified to by default, show the default course role (instead of ALL roles). Now, teachers will have to specifically select ALL to see ALL. No scary surprises and no secret assignments.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: